<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.southpeacenews.com/xmlrpc.php">

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Homicide investigation begins in HP -</title>
	<link rel="canonical" href="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Homicide investigation begins in HP -" />
	<meta property="og:description" content="Chris Clegg South Peace News Alberta RCMP Major Crimes has started an investigation into a homicide in High Prairie. On Nov. 29, at 1:43 a.m., High Prairie RCMP received a firearms complaint in the area of 50 Street and 53 Avenue by the Cozy Corner Pub. “Upon arrival, officers located a victim in a nearby&hellip;" />
	<meta property="og:url" content="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/" />
	<meta property="article:published_time" content="2022-11-29T22:45:04+00:00" />
	<meta property="article:modified_time" content="2022-11-29T22:45:06+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Admin2015" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.southpeacenews.com/#website","url":"https://www.southpeacenews.com/","name":"","description":"","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.southpeacenews.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.southpeacenews.com/homicide-investigation-begins-in-hp/#webpage","url":"https://www.southpeacenews.com/homicide-investigation-begins-in-hp/","name":"Homicide investigation begins in HP -","isPartOf":{"@id":"https://www.southpeacenews.com/#website"},"datePublished":"2022-11-29T22:45:04+00:00","dateModified":"2022-11-29T22:45:06+00:00","author":{"@id":"https://www.southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14"},"breadcrumb":{"@id":"https://www.southpeacenews.com/homicide-investigation-begins-in-hp/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.southpeacenews.com/homicide-investigation-begins-in-hp/"]}]},{"@type":"BreadcrumbList","@id":"https://www.southpeacenews.com/homicide-investigation-begins-in-hp/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.southpeacenews.com/"},{"@type":"ListItem","position":2,"name":"Homicide investigation begins in HP"}]},{"@type":"Person","@id":"https://www.southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14","name":"Admin2015","url":"https://www.southpeacenews.com/author/admin2015/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://www.southpeacenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://www.southpeacenews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Homicide investigation begins in HP Comments Feed" href="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/feed/" />
<link href="http://southpeacenews.com/wp-content/uploads/2017/09/SPN_logo_no_bg.png" rel="icon">
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.southpeacenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css' href='https://www.southpeacenews.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.southpeacenews.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='awesome-weather-css' href='https://www.southpeacenews.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=6.1.1' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-style-css' href='https://www.southpeacenews.com/wp-content/plugins/comments-widget-plus/assets/css/cwp.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='likebtn_style-css' href='https://www.southpeacenews.com/wp-content/plugins/likebtn-like-button/public/css/style.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='colorboxstyle-css' href='https://www.southpeacenews.com/wp-content/plugins/modal-dialog/colorbox/colorbox.css?ver=1.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='rss-feed-pro-css' href='https://www.southpeacenews.com/wp-content/plugins/rss-feed-pro/assets/css/rss-feed-pro.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css' href='https://www.southpeacenews.com/wp-content/plugins/super-rss-reader/public/css/style.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='tptn-style-left-thumbs-css' href='https://www.southpeacenews.com/wp-content/plugins/top-10/css/left-thumbs.min.css?ver=3.2.1' type='text/css' media='all' />
<style id='tptn-style-left-thumbs-inline-css' type='text/css'>

			.tptn-left-thumbs a {
			  width: 150px;
			  height: 150px;
			  text-decoration: none;
			}
			.tptn-left-thumbs img {
				width: 150px;
				max-height: 150px;
				margin: auto;
			}
			.tptn-left-thumbs .tptn_title {
			  width: 100%;
			}
			

			.tptn_posts_widget2 img.tptn_thumb {
				width: 64px !important;
				height: 64px !important;
			}
			
</style>
<link rel='stylesheet' id='rss-retriever-css' href='https://www.southpeacenews.com/wp-content/plugins/wp-rss-retriever/inc/css/rss-retriever.css?ver=1.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/style.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-plugins-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/css/plugins.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/style.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-responsive-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/css/responsive.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-child-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css' href='https://www.southpeacenews.com/wp-content/plugins/custom-facebook-feed/assets/css/cff-style.min.css?ver=4.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.southpeacenews.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14' type='text/css' media='all' />
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='likebtn_frontend-js-extra'>
/* <![CDATA[ */
var likebtn_eh_data = {"ajaxurl":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","security":"a5f45cebd7"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=6.1.1' id='likebtn_frontend-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/modal-dialog/cookie.js?ver=1.0' id='jquerycookies-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/modal-dialog/colorbox/jquery.colorbox-min.js?ver=1.5.6' id='colorboxpack-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/super-rss-reader/public/js/jquery.easy-ticker.min.js?ver=4.8.1' id='jquery-easy-ticker-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/super-rss-reader/public/js/script.min.js?ver=4.8.1' id='super-rss-reader-js'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/js/html5shiv.min.js' id='freshlife-html5-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-image-zoooom/assets/js/jquery.image_zoom.min.js?ver=1.52.1' id='image_zoooom-js'></script>
<script type='text/javascript' id='image_zoooom-init-js-extra'>
/* <![CDATA[ */
var IZ = {"with_woocommerce":"0","exchange_thumbnails":"1","woo_categories":"0","enable_mobile":"","options":{"lensShape":"square","zoomType":"lens","lensSize":400,"borderSize":1,"borderColour":"#ffffff","cursor":"zoom-in","lensFadeIn":0.5,"lensFadeOut":0.5,"tint":"true","tintColour":"#ffffff","tintOpacity":0.1000000000000000055511151231257827021181583404541015625},"woo_slider":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-image-zoooom/assets/js/image_zoom-init.js?ver=1.52.1' id='image_zoooom-init-js'></script>
<link rel="https://api.w.org/" href="https://www.southpeacenews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.southpeacenews.com/wp-json/wp/v2/posts/53894" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.southpeacenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.southpeacenews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
<link rel='shortlink' href='https://www.southpeacenews.com/?p=53894' />
<link rel="alternate" type="application/json+oembed" href="https://www.southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.6.4 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-2 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-3 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-6 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-8 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-9 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:184px; }
	.g-10 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:500px; }
	.g-11 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-14 { margin:0px 0px 0px 0px; width:100%; max-width:1300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

		<style type="text/css">
			.cwp-li {
				overflow: hidden;
			}

			.cwp-avatar {
				float: left;
				margin-top: .2em;
				margin-right: 1em;
			}

			.cwp-avatar.rounded .avatar {
				border-radius: 50%;
			}

			.cwp-avatar.square .avatar {
				border-radius: 0;
			}

			.cwp-comment-excerpt {
				display: block;
				color: #787878;
			}
		</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #173191; }
</style>
	<!-- Custom CSS -->
<style>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</style>
<!-- Generated by https://wordpress.org/plugins/theme-junkie-custom-css/ -->
	<style>

		#primary-nav ul li a:hover, 		 
		#primary-nav ul li.current-menu-item a,
		#secondary-nav ul li a:hover,
		#secondary-nav ul li.current-menu-item a,
                .pagination .page-numbers.current { 
			background-color: #2266bb;
		}

		a:link,
		a:visited,		
		.widget_tabs .tab-content .entry-title a:hover,
		#site-bottom a:hover,
		.category-box ul li strong a:hover,
		.section-title a:hover,
		.widget_latest_comments a:hover .name,
		.related-posts ul li a:hover .entry-title,
		.widget_tabs .tab-content ul li .entry-title:hover,
		.widget_tabs #tab3 li a span:hover,
 		#secondary-nav ul.sf-menu li li a:hover,
		#primary-nav ul.sf-menu li li a:hover,
		#secondary-nav .sf-menu li li a:hover
		.posts .cat-posts .view-more a,
		.posts .cat-posts a:hover .entry-title,
		.header-social a .fa,
		.posts .sub-cats li:hover > a:after,
		.single .entry-meta .entry-author a:hover,
                .pagination .page-numbers {
			color: #2266bb;
		}

		#secondary-nav .sf-mega {
			border-top: 3px solid #2266bb;
		}

		#secondary-bar {
			border-bottom: 3px solid #2266bb;
		}

		.widget_tabs .tabs-nav li.active a,
		.widget_tabs .tabs-nav li a.selected,
		.widget_tabs .tabs-nav li a:hover {
			background-color: #48d;
		}

		.widget_tabs .tabs-nav li a,
                .author-bio {
			background-color: #eef5ff;
		}

		.widget_tabs .tabs-nav {
			border-bottom: 3px solid #48d;
		}

	</style>
	<style type="text/css">img.zoooom,.zoooom img{padding:0!important;}</style><script src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE'></script>
</head>

<body class="post-template-default single single-post postid-53894 single-format-standard custom-background group-blog content-sidebar layout-content-sidebar" itemscope itemtype="http://schema.org/Blog">

<div align="center">

<a href="http://www.southpeacenews.com"><img src="http://southpeacenews.com/wp-content/uploads/2017/02/SPN_WebBanner2017.png"/></a></div>
          



<div id="page" class="container hfeed site clearfix">

	<header id="masthead" class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">

		
	<div id="primary-bar">

			<nav id="primary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

				<ul id="primary-menu" class="primary-menu sf-menu"><li  id="menu-item-25482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25482"><a href="http://southpeacenews.com/">Home</a></li>
<li  id="menu-item-21754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21754"><a target="_blank" href="http://citylive.com/submitted-by-readers">Submit News</a></li>
<li  id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-97"><a href="https://www.southpeacenews.com/ads/">Notices / Employment / Sales / Services</a>
<ul class="sub-menu">
	<li  id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90"><a href="https://www.southpeacenews.com/sales/">ADS Sales</a></li>
	<li  id="menu-item-98" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98"><a href="https://www.southpeacenews.com/notices/">ADS Notices</a></li>
	<li  id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://www.southpeacenews.com/employment/">ADS Employment</a></li>
	<li  id="menu-item-89" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89"><a href="https://www.southpeacenews.com/services/">ADS Services</a></li>
	<li  id="menu-item-93" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93"><a href="https://www.southpeacenews.com/general/">ADS General</a></li>
	<li  id="menu-item-13201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13201"><a href="https://www.southpeacenews.com/promo-items/">ADS SPN Promotional Page</a></li>

</ul>
</li>
<li  id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92"><a href="https://www.southpeacenews.com/horoscopes/">Horoscopes</a></li>
<li  id="menu-item-18637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18637"><a target="_blank" href="http://classified.citylive.com/">Classifieds</a></li>
</ul>
			</nav><!-- #primary-nav -->

			<div class="header-search">
				<form method="get" class="searchform" id="search-form" action="https://www.southpeacenews.com/" role="search">
					<input type="search" class="search-field field" placeholder="Press enter to search &hellip;" value="" name="s" title="Search for:" />
					<button name="search" id="search"><i class="fa fa-search"></i></button>
				</form>
			</div>

	</div>


		<div class="site-branding clearfix">
				<div id="logo">
<h1 class="site-title" itemprop="headline"><a href="https://www.southpeacenews.com" itemprop="url" rel="home"><span itemprop="headline"></span></a></h1>
<h2 class="site-description" itemprop="description"></h2></div>
				    <div id="header-widget-area" class="chw-widget-area widget-area" role="complementary">
    <div class="chw-widget"><!-- Error, Ad is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></div>    </div>
 			
			<div style="margin-bottom: 5px;">
				<div class="g g-9"><div class="g-dyn a-2475 c-1"><a class="gofollow" data-track="MjQ3NSw5LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/SplashOfPretty_Xmas1_dblLEADERBOARD.png" /></a></div><div class="g-dyn a-2487 c-2"><a class="gofollow" data-track="MjQ4Nyw5LDEsNjA=" href="http://www.southpeacenews.com/services/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/08/HPSD_2022_dblLEADERBOARD.png" /></a></div><div class="g-dyn a-2459 c-3"><a class="gofollow" data-track="MjQ1OSw5LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/09/TOHP_Announcements_dblLEADERBOARD.png" /></a></div><div class="g-dyn a-2479 c-4"><a class="gofollow" data-track="MjQ3OSw5LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/10/TOHP_AquaticSchedule_dblLEADERBOARD.png" /></a></div><div class="g-dyn a-2471 c-5"><a class="gofollow" data-track="MjQ3MSw5LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/CanadianRockiesHemp_dblLEADERBOARD.png" /></a></div><div class="g-dyn a-2418 c-6"><a class="gofollow" data-track="MjQxOCw5LDEsNjA=" href="http://southpeacenews.com/services/"><img src="http://www.southpeacenews.com/wp-content/uploads/2021/12/KAFT_dblLEADERBOARD.png" /></a</div><div class="g-dyn a-2483 c-7"><a class="gofollow" data-track="MjQ4Myw5LDEsNjA=" href="https://www.southpeacenews.com/employment/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/Kapown_EmployOpp_dblLEADERBOARD.png" /></a></div><div class="g-dyn a-2434 c-8"><a class="gofollow" data-track="MjQzNCw5LDEsNjA=" href="http://www.southpeacenews.com/northern-sunrise-county-newsletter/"><img src="http://www.southpeacenews.com/wp-content/uploads/2021/08/NorthernSunriseCounty_Newsletter_dblLEADERBOARD.png" /></a></div></div></div>
			<div style="margin-bottom: 5px;">
				<!-- Either there are no banners, they are disabled or none qualified for this location! --></div>
		</div>

			
	<div id="secondary-bar" class="clearfix">

			<nav id="secondary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

				<ul id="secondary-menu" class="secondary-menu sf-menu"><li  id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-47"><a href="https://www.southpeacenews.com/category/news/">News</a>
<ul class="sub-menu">
	<li  id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://www.southpeacenews.com/category/councils/">Councils</a></li>
	<li  id="menu-item-15686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15686"><a href="https://www.southpeacenews.com/category/news/schools/">Schools</a></li>
	<li  id="menu-item-28794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28794"><a href="https://www.southpeacenews.com/category/news/court-docket/">Court Docket</a></li>
	<li  id="menu-item-32254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32254"><a href="https://www.southpeacenews.com/category/news/the-page/">THE PAGE</a></li>

</ul>
</li>
<li  id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.southpeacenews.com/category/sports/">Sports</a></li>
<li  id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55"><a href="https://www.southpeacenews.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li  id="menu-item-14593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14593"><a href="https://www.southpeacenews.com/category/opinion/polls/">Polls</a></li>

</ul>
</li>
<li  id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="https://www.southpeacenews.com/category/events/">Events</a></li>
<li  id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.southpeacenews.com/category/obituaries/">Obituaries</a></li>
<li  id="menu-item-32219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-32219"><a href="https://www.southpeacenews.com/category/extras/">Extras</a>
<ul class="sub-menu">
	<li  id="menu-item-31450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31450"><a href="https://www.southpeacenews.com/kids-talk/">Kids&#8217; Talk</a></li>
	<li  id="menu-item-32220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32220"><a href="https://www.southpeacenews.com/category/extras/inspirations/">Inspiration</a></li>

</ul>
</li>
<li  id="menu-item-27004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27004"><a href="https://www.southpeacenews.com/category/today-in-hp/">Today in HP</a></li>
<li  id="menu-item-42906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42906"><a target="_blank" href="https://www.southpeacenews.com/northern-sunrise-county-newsletter/">Northern Sunrise County Newsletter</a></li>
<li  id="menu-item-32208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32208"><a target="_blank" href="https://www.southpeacenews.com/category/covid-19/">COVID-19</a></li>
<li  id="menu-item-32222" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32222"><a href="https://www.southpeacenews.com/select-contest/">SELECT Tool of the Week Contest</a></li>
</ul>
			</nav><!-- #secondary-nav -->

			
	</div>


	</header><!-- #masthead -->

	<div id="site-content" class="site-content">

	<main id="main" class="site-main clearfix" role="main" class="content">
		<div id="primary" class="content-area">

			<div id="content" class="single">

				<div id="breadcrumbs">

			
		<div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><span class="trail-begin"><a href="https://www.southpeacenews.com" title="" rel="home">Home</a></span>
			 <span class="sep"><i class="fa fa-caret-right"></i></span> <a href="https://www.southpeacenews.com/category/news/" rel="tag">News</a>
			 <span class="sep"><i class="fa fa-caret-right"></i></span> <span class="trail-end">Homicide investigation begins in HP</span>
		</div>	
</div>
				
					<article id="post-53894" class="post-53894 post type-post status-publish format-standard hentry category-news no-post-thumbnail entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

	<header class="entry-header">
		<h1 class="page-title" itemprop="headline">Homicide investigation begins in HP</h1>
				<div class="entry-meta">

				<span class="entry-date">
				<time class="published" datetime="2022-11-29T15:45:04-07:00" itemprop="datePublished">November 29, 2022</time>
			</span>

			<span class="sep">&#183;</span>

			by			
				<span class="entry-author author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a class="url fn n" href="https://www.southpeacenews.com/author/admin2015/" itemprop="url"><span itemprop="name">Admin2015</span></a></span>

			<span class="sep">&#183;</span>

					
							<span class="entry-comments"><i class="fa fa-comment-o"></i> <a href="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/#respond" itemprop="discussionURL">0</a></span>
			
				
		</div>

			</header><!-- .entry-header -->

	
	<div class="entry-content" itemprop="articleBody">
		
<p>Chris Clegg</p>



<p>South Peace News</p>



<p>Alberta RCMP Major Crimes has started an investigation into a homicide in High Prairie.</p>



<p>On Nov. 29, at 1:43 a.m., High Prairie RCMP received a firearms complaint in the area of 50 Street and 53 Avenue by the Cozy Corner Pub.</p>



<p>“Upon arrival, officers located a victim in a nearby vehicle,” says Cpl. Troy Savinkoff, Media Relations Officer, Alberta RCMP Media Group.</p>



<p>“Unfortunately, the victim, a 37-year old male resident of High Prairie, was deceased at the scene,” he adds.</p>



<p>Police did not release his name.</p>



<p>Alberta RCMP Major Crimes Unit was deployed to High Prairie to investigate and arrived in town hours later.</p>



<p>“Although early in the investigation, RCMP believe that this is a targeted event and there is no ongoing threat to the community,” says Savinkoff.</p>



<p>The investigation continues.</p>



<p></p>
<div class="likebtn_container" style="clear:both;text-align:center;"><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="post_53894"  data-site_id="5a85da066fd08b8d780a138a"  data-theme="large"  data-ef_voting="heartbeat"  data-show_dislike_label="true"  data-counter_type="percent"  data-voting_frequency="604800"  data-white_label="true"  data-rich_snippet="true"  data-i18n_like="This informed me"  data-i18n_dislike="This not needed"  data-i18n_after_like="Liked"  data-i18n_after_dislike="Disliked"  data-i18n_like_tooltip="I found the content of this post interesting"  data-i18n_dislike_tooltip="This post did not interest me"  data-i18n_unlike_tooltip="I liked this already"  data-i18n_undislike_tooltip="I disliked this already"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/"  data-item_title="Homicide investigation begins in HP"  data-item_date="2022-11-29T15:45:04-07:00"  data-engine="WordPress"  data-plugin_v="2.6.47"  data-prx="https://www.southpeacenews.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh" ></span><!-- LikeBtn.com END --></div><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- AdsenseResponsive01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3165736599172791"
     data-ad-slot="6075938174"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!-- .entry-content -->

	<footer class="entry-footer">

		<span class="entry-cats"><strong>Filed in:</strong> <a href="https://www.southpeacenews.com/category/news/" rel="category tag">News</a></span>
	</footer><!-- .entry-footer -->

	<div class="clearfix"></div>

	
			<div class="entry-share clearfix">
			<h3>Share this post</h3>
			<ul>
				<li class="twitter"><a href="https://twitter.com/intent/tweet?text=Homicide investigation begins in HP&url=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F" target="_blank"><i class="fa fa-twitter"></i>Twitter</a></li>
				<li class="facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F" target="_blank"><i class="fa fa-facebook"></i>Facebook</a></li>
				<li class="google-plus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F" target="_blank"><i class="fa fa-google-plus"></i>Google+</a></li>
				<li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F&title=Homicide investigation begins in HP" target="_blank"><i class="fa fa-linkedin"></i>LinkedIn</a></li>
				<li class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.southpeacenews.com%2Fhomicide-investigation-begins-in-hp%2F&media=" target="_blank"><i class="fa fa-pinterest"></i>Pinterest</a></li>				
				<li class="email"><a href="mailto:"><i class="fa fa-envelope-o"></i>Email</a></li>
			</ul>
		</div><!-- .entry-share -->
		
	
			<div class="related-posts">
				<h3>Recommended for You</h3>
				<ul class="clearfix">
											<li>
							<a href="https://www.southpeacenews.com/school-news-prjh-mathlete-minions-prepare-for-competitions/">
									<img width="200" height="113" src="https://www.southpeacenews.com/wp-content/uploads/2022/11/PRJH-Rossie-Milsap-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="School News &#8211; PRJH Mathlete Minions prepare for competitions" decoding="async" itemprop="image" />								<h2 class="entry-title">School News &#8211; PRJH Mathlete Minions prepare for competitions</h2>							</a>
						</li>
											<li>
							<a href="https://www.southpeacenews.com/the-page-november-23-2022/">
																	<h2 class="entry-title">The Page &#8211; November 23, 2022</h2>							</a>
						</li>
											<li>
							<a href="https://www.southpeacenews.com/winagami-wading-pool-a-high-priority-for-loewen/">
									<img width="200" height="113" src="https://www.southpeacenews.com/wp-content/uploads/2022/11/Todd-Loewen-2022-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Winagami wading pool a high priority for Loewen" decoding="async" loading="lazy" itemprop="image" />								<h2 class="entry-title">Winagami wading pool a high priority for Loewen</h2>							</a>
						</li>
											<li>
							<a href="https://www.southpeacenews.com/king-murder-story-wins-ccna-award/">
																	<h2 class="entry-title">King murder story wins CCNA award</h2>							</a>
						</li>
									</ul>
			</div>
		
			
</article><!-- #post-## -->
					
<div id="comments" class="comments-area">

	
	
	
				<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Post Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/homicide-investigation-begins-in-hp/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.southpeacenews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment <span class="required">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author"> Name <span class="required">*</span></label> <input class="txt" id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email"> Email <span class="required">*</span></label> <input class="txt" id="email" name="email" type="email" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url"> Website</label> <input class="txt" id="url" name="url" type="url" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='53894' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c8d7059c4b" /></p><input class="btn" name="submit" type="submit" id="submit" value="Post Comment" /><input type="hidden" id="ak_js" name="ak_js" value="157"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
		
</div><!-- #comments -->
				
			</div>

		</div><!-- #primary -->

		
<div id="secondary" class="widget-area widget-primary sidebar" role="complementary" aria-label="Primary Sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://highprairie.citylive.com/hp-events-calendar/" target="_blank" rel="noopener"><img src="http://highprairie.com/wp-content/uploads/2016/11/Calendar_Small_Banner.png" alt="click for the High Prairie & Area Events Calendar"></a>
</div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- AdsenseResponsive01 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3165736599172791"
     data-ad-slot="6075938174"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="ajdg_grpwidgets-2" class="widget ajdg_grpwidgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="ajdg_grpwidgets-12" class="widget ajdg_grpwidgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="awesomeweatherwidget-4" class="widget widget_awesomeweatherwidget"><div id="awe-ajax-awesome-weather-peace-river-ab" class="awe-ajax-awesome-weather-peace-river-ab awe-weather-ajax-wrap" style=""><div class="awe-loading"><i class="wi wi-day-sunny"></i></div></div><script type="text/javascript"> jQuery(document).ready(function() { awe_ajax_load({"id":"awesome-weather-peace-river-ab","locale":"","location":"PEACE RIVER AB","owm_city_id":"6100069","override_title":"HIGH PRAIRIE - PEACE RIVER ","size":"wide","units":"C","forecast_days":"10","hide_stats":0,"show_link":0,"background":"","custom_bg_color":"","use_user_location":0,"allow_user_to_change":0,"show_icons":0,"extended_url":"","extended_text":"","background_by_weather":1,"text_color":"#eeee22","hide_attribution":1,"skip_geolocate":0,"latlng":"","ajaxurl":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","via_ajax":1}); }); </script></aside><aside id="text-2" class="widget widget_text">			<div class="textwidget"><center><p><a href ="https://weather.gc.ca/city/pages/ab-25_metric_e.html"><img src ="http://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif"</img>   Environment Canada Forecast   <img src ="http://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif"</img></a></p><p><a href="https://511.alberta.ca/map#:Alerts"><img src ="http://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif"</img>   Alberta 511 Road Reports   <img src ="http://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif"</a></P>
<p><a href ="https://wildfire.alberta.ca/wildfire-status/status-map.aspx"><img src ="http://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png"</img>   Alberta Wildfire Status Map   <img src ="http://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png"</img></a></p></center></div>
		</aside><aside id="cwp-widget-2" class="widget widget_recent_comments comments_widget_plus"><h3 class="widget-title">Recent Comments</h3><ul class="cwp-ul "><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/grand-chief-elders-take-prsd-to-class-on-treaty-8/#comment-14802"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">K. Bains</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/grand-chief-elders-take-prsd-to-class-on-treaty-8/#comment-14802">Grand chief, Elders take PRSD to class on Treaty 8</a></span><span class="comment-excerpt cwp-comment-excerpt">Indigenous leaders should focus on the positives in their lives and present studen&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/editorial-resignation-is-welcome-news/#comment-14797"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Deborah Apps</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/editorial-resignation-is-welcome-news/#comment-14797">Editorial &#8211; Resignation is welcome news</a></span><span class="comment-excerpt cwp-comment-excerpt">Dear Jeff Burger, I would like to clarify that I was not a member of the Executive&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/solar-streetlights-proposed-for-joussard/#comment-14775"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">David Lainchbury</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/solar-streetlights-proposed-for-joussard/#comment-14775">Solar streetlights proposed for Joussard</a></span><span class="comment-excerpt cwp-comment-excerpt">Solar street lights while dumping raw sewage into the lake causing Toxic blue gree&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/solar-streetlights-proposed-for-joussard/#comment-14774"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Dave Lauck</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/solar-streetlights-proposed-for-joussard/#comment-14774">Solar streetlights proposed for Joussard</a></span><span class="comment-excerpt cwp-comment-excerpt">And yet the county can hardly deliver road maintenance to where I live. It must be&hellip;</span></li></ul><!-- Generated by https://wordpress.org/plugins/comments-widget-plus/ --></aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><h3 class="widget-title">Your Thoughts Are Welcome</h3><div class="textwidget custom-html-widget">Comments for particular stories should go on the comment section below that story. General comments submit <a href="http://southpeacenews.com/general-comments/">HERE</a></div></aside><aside id="media_image-2" class="widget widget_media_image"><img width="304" height="54" src="https://www.southpeacenews.com/wp-content/uploads/2022/09/LJI_Gov_Banner.png" class="image wp-image-52241  attachment-full size-full" alt="" decoding="async" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/09/LJI_Gov_Banner.png 304w, https://www.southpeacenews.com/wp-content/uploads/2022/09/LJI_Gov_Banner-245x44.png 245w, https://www.southpeacenews.com/wp-content/uploads/2022/09/LJI_Gov_Banner-64x11.png 64w, https://www.southpeacenews.com/wp-content/uploads/2022/09/LJI_Gov_Banner-300x54.png 300w" sizes="(max-width: 304px) 100vw, 304px" itemprop="image" /></aside><aside id="ajdg_grpwidgets-3" class="widget ajdg_grpwidgets"><div class="g g-10"><div class="g-dyn a-2433 c-1"><a class="gofollow" data-track="MjQzMywxMCwxLDYw" href="http://www.southpeacenews.com/northern-sunrise-county-newsletter/"><img src="http://www.southpeacenews.com/wp-content/uploads/2021/08/NorthernSunriseCounty_Newsletter_BIGBOX.png" /></a></div><div class="g-dyn a-2482 c-2"><a class="gofollow" data-track="MjQ4MiwxMCwxLDYw" href="https://www.southpeacenews.com/employment/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/Kapown_EmployOpp_BIGBOX.png" /></a></div><div class="g-dyn a-2474 c-3"><a class="gofollow" data-track="MjQ3NCwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/SplashOfPretty_xmas1_BIGBOX.png" /></a></div><div class="g-dyn a-2478 c-4"><a class="gofollow" data-track="MjQ3OCwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/10/TOHP_AquaticSchedule_BIGBOX.png" /></a></div><div class="g-dyn a-2458 c-5"><a class="gofollow" data-track="MjQ1OCwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/09/TOHP_Announcements_BIGBOX.png" /></a></div><div class="g-dyn a-2486 c-6"><a class="gofollow" data-track="MjQ4NiwxMCwxLDYw" href="http://www.southpeacenews.com/services/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/HPSD_DEC_BIGBOX.png" /></a></div><div class="g-dyn a-2417 c-7"><a class="gofollow" data-track="MjQxNywxMCwxLDYw" href="http://southpeacenews.com/services/"><img src="http://www.southpeacenews.com/wp-content/uploads/2021/12/KAFT_BIGBOX.png" /></a></div><div class="g-dyn a-2447 c-8"><a class="gofollow" data-track="MjQ0NywxMCwxLDYw" href="https://www.southpeacenews.com/employment/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/HPSD_NOV_BIGBOX.png" /></a></div><div class="g-dyn a-2470 c-9"><a class="gofollow" data-track="MjQ3MCwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/CanadianRockiesHemp_BIGBOX.png" /></a></div></div></aside><aside id="widget_tptn_pop-2" class="widget tptn_posts_list_widget"><h3 class="widget-title">&#8212;&#8212; MOST READ STORIES &#8211; PAST 14 DAYS &#8212;&#8212;</h3><div class="tptn_posts_daily  tptn_posts_widget tptn_posts_widget2    tptn-left-thumbs"><ul><li><a href="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/"     class="tptn_link"><img loading="lazy"  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb thumbnail" alt="Homicide investigation begins in HP" title="Homicide investigation begins in HP" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/homicide-investigation-begins-in-hp/"     class="tptn_link"><span class="tptn_title">Homicide investigation begins in HP</span></a><span class="tptn_excerpt"> Chris Clegg South Peace News Alberta RCMP Major Crimes has started an investigation into a homicide in High&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/exemplary-service-of-pr-fire-chief-recognized-rewarded/"     class="tptn_link"><img loading="lazy"  width="64" height="46"  src="https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9973-scaled-e1668810269825-64x46.jpg" class="tptn_thumb tptn_featured thumbnail" alt="Exemplary service of PR fire chief recognized, rewarded" title="Exemplary service of PR fire chief recognized, rewarded" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9973-scaled-e1668810269825-64x46.jpg 64w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9973-scaled-e1668810269825-209x150.jpg 209w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9973-scaled-e1668810269825-768x550.jpg 768w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9973-scaled-e1668810269825-300x215.jpg 300w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9973-scaled-e1668810269825.jpg 800w" sizes="(max-width: 64px) 100vw, 64px" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/exemplary-service-of-pr-fire-chief-recognized-rewarded/"     class="tptn_link"><span class="tptn_title">Exemplary service of PR fire chief recognized, rewarded</span></a><span class="tptn_excerpt"> Town of Peace River Mayor Elaine Manzer, right, presents Peace River Fire Department fire chief Tim Harris with&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/upgrade-celebrated/"     class="tptn_link"><img loading="lazy"  width="64" height="43"  src="https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9952-scaled-e1669070167366-64x43.jpg" class="tptn_thumb tptn_featured thumbnail" alt="Upgrade celebrated" title="Upgrade celebrated" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9952-scaled-e1669070167366-64x43.jpg 64w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9952-scaled-e1669070167366-225x150.jpg 225w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9952-scaled-e1669070167366-768x512.jpg 768w, https://www.southpeacenews.com/wp-content/uploads/2022/11/IMG_9952-scaled-e1669070167366.jpg 800w" sizes="(max-width: 64px) 100vw, 64px" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/upgrade-celebrated/"     class="tptn_link"><span class="tptn_title">Upgrade celebrated</span></a><span class="tptn_excerpt"> On Nov. 14, Peace River town council celebrated the opening of the upgraded Lift Station 4 in Lower&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/court-docket-98-fine-deemed-paid-by-court-appearance/"     class="tptn_link"><img loading="lazy"  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb thumbnail" alt="Court Docket - $98 fine deemed paid by court appearance" title="Court Docket - $98 fine deemed paid by court appearance" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/court-docket-98-fine-deemed-paid-by-court-appearance/"     class="tptn_link"><span class="tptn_title">Court Docket &#8211; $98 fine deemed paid by court&hellip;</span></a><span class="tptn_excerpt"> H.P, court docketNov. 7, 2022Judge S.P. Hinkley A 36-year-old male was fined less than $100 for causing damage&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/buchanan-family-donates-to-columbarium-memorial-wall/"     class="tptn_link"><img loading="lazy"  width="64" height="43"  src="https://www.southpeacenews.com/wp-content/uploads/2022/11/Anglican-Church-7555-e1668470679707-64x43.jpg" class="tptn_thumb tptn_featured thumbnail" alt="Buchanan family donates to Columbarium, memorial wall" title="Buchanan family donates to Columbarium, memorial wall" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/11/Anglican-Church-7555-e1668470679707-64x43.jpg 64w, https://www.southpeacenews.com/wp-content/uploads/2022/11/Anglican-Church-7555-e1668470679707-225x150.jpg 225w, https://www.southpeacenews.com/wp-content/uploads/2022/11/Anglican-Church-7555-e1668470679707-768x512.jpg 768w, https://www.southpeacenews.com/wp-content/uploads/2022/11/Anglican-Church-7555-e1668470679707.jpg 800w" sizes="(max-width: 64px) 100vw, 64px" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/buchanan-family-donates-to-columbarium-memorial-wall/"     class="tptn_link"><span class="tptn_title">Buchanan family donates to Columbarium, memorial wall</span></a><span class="tptn_excerpt"> Photos by Jodi Sware Members of the Buchanan family pose beside the Columbarium, Left-right are Greg and Donna&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/red-wings-pay-tribute-on-remembrance-day/"     class="tptn_link"><img loading="lazy"  width="64" height="43"  src="https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0013-e1669132215931-64x43.jpg" class="tptn_thumb tptn_featured thumbnail" alt="Red Wings pay tribute on Remembrance Day" title="Red Wings pay tribute on Remembrance Day" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0013-e1669132215931-64x43.jpg 64w, https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0013-e1669132215931-225x150.jpg 225w, https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0013-e1669132215931-768x512.jpg 768w, https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0013-e1669132215931.jpg 800w" sizes="(max-width: 64px) 100vw, 64px" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/red-wings-pay-tribute-on-remembrance-day/"     class="tptn_link"><span class="tptn_title">Red Wings pay tribute on Remembrance Day</span></a><span class="tptn_excerpt"> A ceremonial faceoff was held Nov. 11 at the GMHL game between the High Prairie Red Wings and&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/today-in-high-prairie-november-29-2022/"     class="tptn_link"><img loading="lazy"  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb thumbnail" alt="Today in High Prairie: November 29, 2022" title="Today in High Prairie: November 29, 2022" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/today-in-high-prairie-november-29-2022/"     class="tptn_link"><span class="tptn_title">Today in High Prairie: November 29, 2022</span></a><span class="tptn_excerpt"> Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/grand-chief-elders-take-prsd-to-class-on-treaty-8/"     class="tptn_link"><img loading="lazy"  width="64" height="32"  src="https://www.southpeacenews.com/wp-content/uploads/2022/11/15-PRSD-Treaty8-e1668468144978-64x32.jpg" class="tptn_thumb tptn_featured thumbnail" alt="Grand chief, Elders take PRSD to class on Treaty 8" title="Grand chief, Elders take PRSD to class on Treaty 8" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/11/15-PRSD-Treaty8-e1668468144978-64x32.jpg 64w, https://www.southpeacenews.com/wp-content/uploads/2022/11/15-PRSD-Treaty8-e1668468144978-245x123.jpg 245w, https://www.southpeacenews.com/wp-content/uploads/2022/11/15-PRSD-Treaty8-e1668468144978-768x384.jpg 768w, https://www.southpeacenews.com/wp-content/uploads/2022/11/15-PRSD-Treaty8-e1668468144978.jpg 800w" sizes="(max-width: 64px) 100vw, 64px" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/grand-chief-elders-take-prsd-to-class-on-treaty-8/"     class="tptn_link"><span class="tptn_title">Grand chief, Elders take PRSD to class on Treaty 8</span></a><span class="tptn_excerpt"> Peace River School Division received a flag Oct. 24 from Treaty 8 First Nations of Alberta. Standing, left-right,&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/today-in-high-prairie-november-30-2022/"     class="tptn_link"><img loading="lazy"  width="64" height="64"  src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb thumbnail" alt="Today in High Prairie: November 30, 2022" title="Today in High Prairie: November 30, 2022" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/today-in-high-prairie-november-30-2022/"     class="tptn_link"><span class="tptn_title">Today in High Prairie: November 30, 2022</span></a><span class="tptn_excerpt"> Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/team-inspired-by-huge-home-crowd/"     class="tptn_link"><img loading="lazy"  width="64" height="48"  src="https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0026-e1669132246225-64x48.jpg" class="tptn_thumb tptn_featured thumbnail" alt="Team inspired by huge home crowd" title="Team inspired by huge home crowd" srcset="https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0026-e1669132246225-64x48.jpg 64w, https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0026-e1669132246225-199x150.jpg 199w, https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0026-e1669132246225-768x579.jpg 768w, https://www.southpeacenews.com/wp-content/uploads/2022/11/18-DSC_0026-e1669132246225.jpg 800w" sizes="(max-width: 64px) 100vw, 64px" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/team-inspired-by-huge-home-crowd/"     class="tptn_link"><span class="tptn_title">Team inspired by huge home crowd</span></a><span class="tptn_excerpt"> High Prairie Red Wing player Hudson Chalifoux, right, plays the puck beside the Enoch Northern Alberta Tomahawk net&hellip;</span></span></li></ul><div class="tptn_clear"></div></div></aside><aside id="ajdg_grpwidgets-11" class="widget ajdg_grpwidgets"><div class="g g-1"><div class="g-dyn a-2480 c-1"><a class="gofollow" data-track="MjQ4MCwxLDEsNjA=" href="https://www.southpeacenews.com/employment/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/Kapown_EmployOpp_SIDE.png" /></a></div><div class="g-dyn a-2472 c-2"><a class="gofollow" data-track="MjQ3MiwxLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/SplashOfPretty_Xmas1_SIDE.png" /></a></div><div class="g-dyn a-2468 c-3"><a class="gofollow" data-track="MjQ2OCwxLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/11/CanadianRockiesHemp_SIDE.png" /></a></div><div class="g-dyn a-2431 c-4"><a class="gofollow" data-track="MjQzMSwxLDEsNjA=" href="http://www.southpeacenews.com/northern-sunrise-county-newsletter/"><img src="http://www.southpeacenews.com/wp-content/uploads/2021/08/NorthernSunriseCounty_Newsletter_SIDE.png" /></a></div><div class="g-dyn a-2409 c-5"><a class="gofollow" data-track="MjQwOSwxLDEsNjA=" href="https://southpeacenews.com/select-contest/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Select_TooloftheWeek_SIDE.png" /></a></div><div class="g-dyn a-2415 c-6"><a class="gofollow" data-track="MjQxNSwxLDEsNjA=" href="http://southpeacenews.com/services/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/08/Kaft_BusDir_both_SIDE.png" /></a></div><div class="g-dyn a-2484 c-7"><a class="gofollow" data-track="MjQ4NCwxLDEsNjA=" href="http://www.southpeacenews.com/services/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/08/HPSD_2022_SIDE.png" /></a></div><div class="g-dyn a-2476 c-8"><a class="gofollow" data-track="MjQ3NiwxLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/10/TOHP_AquaticSchedule_SIDE.png" /></a></div><div class="g-dyn a-2456 c-9"><a class="gofollow" data-track="MjQ1NiwxLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="http://www.southpeacenews.com/wp-content/uploads/2022/09/TOHP_Announcements_SIDE.png" /></a></div></div></aside><aside id="super_rss_reader-2" class="widget widget_super_rss_reader"><h3 class="widget-title">THEREGIONAL EXCERPTS &#8211; HEADLINES BELOW</h3><!-- Start - Super RSS Reader v4.8.1-->
        <div class="super-rss-reader-widget"><div class="srr-main"><div class="srr-wrap srr-style-grey" data-visible="20" data-speed="4000" data-id="srr-tab-545"><div><div class="srr-item "><div class="srr-clearfix"><div class="srr-title"><a href="https://www.theregional.com/go-wild-and-untamed-shopping-in-fairmont-bc/" target="_blank" rel="nofollow noopener noreferrer" title="Go ‘Wild and Untamed’ shopping in Fairmont BC">Go ‘Wild and Untamed’ shopping in Fairmont BC</a></div><div class="srr-summary srr-clearfix"><p>Métis artist and business owner, Kate Hagstrom, has always prided herself on creating one-of-a-kind items. She owns and operates  Wild and Untamed Studio in Fairmont Hot Springs.  About the business that she has been running&hellip; <a href="https://www.theregional.com/go-wild-and-untamed-shopping-in-fairmont-bc/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[... Read More ]</a></p></div></div></div><div class="srr-item srr-stripe"><div class="srr-clearfix"><div class="srr-title"><a href="https://www.theregional.com/northwest-alberta-ski-hill-needs-workers-upgrades/" target="_blank" rel="nofollow noopener noreferrer" title="Northwest Alberta ski hill needs workers, upgrades">Northwest Alberta ski hill needs workers, upgrades</a></div><div class="srr-summary srr-clearfix"><p>Nitehawk Year-round Adventure Park came to city council last Monday (Nov. 14) looking for funding support.  Nitehawk asked council for an additional $19,000, bringing the total to $192,000 for the 2023 season. The additional amount&hellip; <a href="https://www.theregional.com/northwest-alberta-ski-hill-needs-workers-upgrades/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[... Read More ]</a></p></div></div></div><div class="srr-item "><div class="srr-clearfix"><div class="srr-title"><a href="https://www.theregional.com/ontario-woman-does-bike-kayak-biathlon-after-double-leg-amputation/" target="_blank" rel="nofollow noopener noreferrer" title="Ontario woman does bike, kayak biathlon after double leg amputation">Ontario woman does bike, kayak biathlon after double leg amputation</a></div><div class="srr-summary srr-clearfix"><p>Kaleen Torbiak hopes her story of adversity and self-perseverance will inspire others. The double leg amputee from Atikokan finished a 193-km-long kayaking and biking biathlon in Florida this weekend. “Sunday was such an emotional roller&hellip; <a href="https://www.theregional.com/ontario-woman-does-bike-kayak-biathlon-after-double-leg-amputation/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[... Read More ]</a></p></div></div></div><div class="srr-item srr-stripe"><div class="srr-clearfix"><div class="srr-title"><a href="https://www.theregional.com/parks-canada-offers-its-safety-message-for-jasper-ab/" target="_blank" rel="nofollow noopener noreferrer" title="Parks Canada offers its safety message for Jasper AB">Parks Canada offers its safety message for Jasper AB</a></div><div class="srr-summary srr-clearfix"><p>The problem with receiving more than two million visitors every year in Jasper National Park is that not all of them know what it means to drive safely down the Icefields Parkway or stay safe&hellip; <a href="https://www.theregional.com/parks-canada-offers-its-safety-message-for-jasper-ab/" title="Read more" target="_blank" rel="nofollow noopener noreferrer" class="srr-read-more">[... Read More ]</a></p></div></div></div></div></div></div></div><!-- End - Super RSS Reader --></aside></div><!-- #secondary -->
	</main><!-- #main -->

	</div><!-- #content -->

	<div class="clearfix"></div>

	<footer id="footer" class="site-footer clearfix" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
			
			<div class="footer-column footer-column-1">
				<aside id="text-4" class="widget widget_text"><h3 class="widget-title">SUPPORT INFORMATION</h3>			<div class="textwidget"><p><a href="https://southpeacenews.com/get-alerts/">Sign Up for Email Alerts</a><br />
<a href="http://southpeacenews.com/contact/">Contact Us</a><br />
<a href="http://southpeacenews.com/about/">About The South Peace News</a><br />
<a href="http://southpeacenews.com/advertising-rates/">Online Advertising Rates</a></p>
</div>
		</aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">ARCHIVES</h3>		<label class="screen-reader-text" for="archives-dropdown-2">ARCHIVES</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.southpeacenews.com/2022/11/'> November 2022 &nbsp;(149)</option>
	<option value='https://www.southpeacenews.com/2022/10/'> October 2022 &nbsp;(179)</option>
	<option value='https://www.southpeacenews.com/2022/09/'> September 2022 &nbsp;(134)</option>
	<option value='https://www.southpeacenews.com/2022/08/'> August 2022 &nbsp;(105)</option>
	<option value='https://www.southpeacenews.com/2022/07/'> July 2022 &nbsp;(162)</option>
	<option value='https://www.southpeacenews.com/2022/06/'> June 2022 &nbsp;(156)</option>
	<option value='https://www.southpeacenews.com/2022/05/'> May 2022 &nbsp;(147)</option>
	<option value='https://www.southpeacenews.com/2022/04/'> April 2022 &nbsp;(198)</option>
	<option value='https://www.southpeacenews.com/2022/03/'> March 2022 &nbsp;(172)</option>
	<option value='https://www.southpeacenews.com/2022/02/'> February 2022 &nbsp;(156)</option>
	<option value='https://www.southpeacenews.com/2022/01/'> January 2022 &nbsp;(161)</option>
	<option value='https://www.southpeacenews.com/2021/12/'> December 2021 &nbsp;(110)</option>
	<option value='https://www.southpeacenews.com/2021/11/'> November 2021 &nbsp;(175)</option>
	<option value='https://www.southpeacenews.com/2021/10/'> October 2021 &nbsp;(156)</option>
	<option value='https://www.southpeacenews.com/2021/09/'> September 2021 &nbsp;(178)</option>
	<option value='https://www.southpeacenews.com/2021/08/'> August 2021 &nbsp;(108)</option>
	<option value='https://www.southpeacenews.com/2021/07/'> July 2021 &nbsp;(128)</option>
	<option value='https://www.southpeacenews.com/2021/06/'> June 2021 &nbsp;(165)</option>
	<option value='https://www.southpeacenews.com/2021/05/'> May 2021 &nbsp;(135)</option>
	<option value='https://www.southpeacenews.com/2021/04/'> April 2021 &nbsp;(104)</option>
	<option value='https://www.southpeacenews.com/2021/03/'> March 2021 &nbsp;(135)</option>
	<option value='https://www.southpeacenews.com/2021/02/'> February 2021 &nbsp;(122)</option>
	<option value='https://www.southpeacenews.com/2021/01/'> January 2021 &nbsp;(123)</option>
	<option value='https://www.southpeacenews.com/2020/12/'> December 2020 &nbsp;(160)</option>
	<option value='https://www.southpeacenews.com/2020/11/'> November 2020 &nbsp;(159)</option>
	<option value='https://www.southpeacenews.com/2020/10/'> October 2020 &nbsp;(153)</option>
	<option value='https://www.southpeacenews.com/2020/09/'> September 2020 &nbsp;(174)</option>
	<option value='https://www.southpeacenews.com/2020/08/'> August 2020 &nbsp;(121)</option>
	<option value='https://www.southpeacenews.com/2020/07/'> July 2020 &nbsp;(148)</option>
	<option value='https://www.southpeacenews.com/2020/06/'> June 2020 &nbsp;(180)</option>
	<option value='https://www.southpeacenews.com/2020/05/'> May 2020 &nbsp;(182)</option>
	<option value='https://www.southpeacenews.com/2020/04/'> April 2020 &nbsp;(219)</option>
	<option value='https://www.southpeacenews.com/2020/03/'> March 2020 &nbsp;(216)</option>
	<option value='https://www.southpeacenews.com/2020/02/'> February 2020 &nbsp;(123)</option>
	<option value='https://www.southpeacenews.com/2020/01/'> January 2020 &nbsp;(146)</option>
	<option value='https://www.southpeacenews.com/2019/12/'> December 2019 &nbsp;(152)</option>
	<option value='https://www.southpeacenews.com/2019/11/'> November 2019 &nbsp;(147)</option>
	<option value='https://www.southpeacenews.com/2019/10/'> October 2019 &nbsp;(182)</option>
	<option value='https://www.southpeacenews.com/2019/09/'> September 2019 &nbsp;(143)</option>
	<option value='https://www.southpeacenews.com/2019/08/'> August 2019 &nbsp;(109)</option>
	<option value='https://www.southpeacenews.com/2019/07/'> July 2019 &nbsp;(179)</option>
	<option value='https://www.southpeacenews.com/2019/06/'> June 2019 &nbsp;(148)</option>
	<option value='https://www.southpeacenews.com/2019/05/'> May 2019 &nbsp;(135)</option>
	<option value='https://www.southpeacenews.com/2019/04/'> April 2019 &nbsp;(156)</option>
	<option value='https://www.southpeacenews.com/2019/03/'> March 2019 &nbsp;(117)</option>
	<option value='https://www.southpeacenews.com/2019/02/'> February 2019 &nbsp;(75)</option>
	<option value='https://www.southpeacenews.com/2019/01/'> January 2019 &nbsp;(128)</option>
	<option value='https://www.southpeacenews.com/2018/12/'> December 2018 &nbsp;(90)</option>
	<option value='https://www.southpeacenews.com/2018/11/'> November 2018 &nbsp;(141)</option>
	<option value='https://www.southpeacenews.com/2018/10/'> October 2018 &nbsp;(133)</option>
	<option value='https://www.southpeacenews.com/2018/09/'> September 2018 &nbsp;(111)</option>
	<option value='https://www.southpeacenews.com/2018/08/'> August 2018 &nbsp;(108)</option>
	<option value='https://www.southpeacenews.com/2018/07/'> July 2018 &nbsp;(152)</option>
	<option value='https://www.southpeacenews.com/2018/06/'> June 2018 &nbsp;(120)</option>
	<option value='https://www.southpeacenews.com/2018/05/'> May 2018 &nbsp;(138)</option>
	<option value='https://www.southpeacenews.com/2018/04/'> April 2018 &nbsp;(135)</option>
	<option value='https://www.southpeacenews.com/2018/03/'> March 2018 &nbsp;(151)</option>
	<option value='https://www.southpeacenews.com/2018/02/'> February 2018 &nbsp;(134)</option>
	<option value='https://www.southpeacenews.com/2018/01/'> January 2018 &nbsp;(119)</option>
	<option value='https://www.southpeacenews.com/2017/12/'> December 2017 &nbsp;(133)</option>
	<option value='https://www.southpeacenews.com/2017/11/'> November 2017 &nbsp;(140)</option>
	<option value='https://www.southpeacenews.com/2017/10/'> October 2017 &nbsp;(152)</option>
	<option value='https://www.southpeacenews.com/2017/09/'> September 2017 &nbsp;(130)</option>
	<option value='https://www.southpeacenews.com/2017/08/'> August 2017 &nbsp;(113)</option>
	<option value='https://www.southpeacenews.com/2017/07/'> July 2017 &nbsp;(138)</option>
	<option value='https://www.southpeacenews.com/2017/06/'> June 2017 &nbsp;(153)</option>
	<option value='https://www.southpeacenews.com/2017/05/'> May 2017 &nbsp;(159)</option>
	<option value='https://www.southpeacenews.com/2017/04/'> April 2017 &nbsp;(144)</option>
	<option value='https://www.southpeacenews.com/2017/03/'> March 2017 &nbsp;(142)</option>
	<option value='https://www.southpeacenews.com/2017/02/'> February 2017 &nbsp;(118)</option>
	<option value='https://www.southpeacenews.com/2017/01/'> January 2017 &nbsp;(117)</option>
	<option value='https://www.southpeacenews.com/2016/12/'> December 2016 &nbsp;(151)</option>
	<option value='https://www.southpeacenews.com/2016/11/'> November 2016 &nbsp;(136)</option>
	<option value='https://www.southpeacenews.com/2016/10/'> October 2016 &nbsp;(178)</option>
	<option value='https://www.southpeacenews.com/2016/09/'> September 2016 &nbsp;(154)</option>
	<option value='https://www.southpeacenews.com/2016/08/'> August 2016 &nbsp;(147)</option>
	<option value='https://www.southpeacenews.com/2016/07/'> July 2016 &nbsp;(153)</option>
	<option value='https://www.southpeacenews.com/2016/06/'> June 2016 &nbsp;(172)</option>
	<option value='https://www.southpeacenews.com/2016/05/'> May 2016 &nbsp;(159)</option>
	<option value='https://www.southpeacenews.com/2016/04/'> April 2016 &nbsp;(73)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside><aside id="text-10" class="widget widget_text"><h3 class="widget-title">PURLS To Brighten Your Day</h3>			<div class="textwidget"><p>Advertiser Sale of The Week &#8211; Coming<br />
Recipe &#8211; Coming<br />
Canada Home of The Week &#8211; Coming<br />
Coffee Break &#8211; Coming<br />
Top Headline &#8211; Coming</p>
<p>&nbsp;</p>
</div>
		</aside><aside id="text-11" class="widget widget_text"><h3 class="widget-title">LINKS FROM STORIES</h3>			<div class="textwidget"><p><a href="http://www.southpeacenews.com/interesting-links-from-stories/" rel="noopener" target="_blank">Interesting Links from Stories</a></p>
</div>
		</aside>			</div>

			<div class="footer-column footer-column-2">
				<aside id="rss-2" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget rss-widget-feed" href="http://theregional.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.southpeacenews.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.theregional.com/">THEREGIONAL &#8211; Community News From Across Canada</a></h3><ul><li><a class='rsswidget' href='https://www.theregional.com/go-wild-and-untamed-shopping-in-fairmont-bc/'>Go ‘Wild and Untamed’ shopping in Fairmont BC</a></li><li><a class='rsswidget' href='https://www.theregional.com/northwest-alberta-ski-hill-needs-workers-upgrades/'>Northwest Alberta ski hill needs workers, upgrades</a></li><li><a class='rsswidget' href='https://www.theregional.com/ontario-woman-does-bike-kayak-biathlon-after-double-leg-amputation/'>Ontario woman does bike, kayak biathlon after double leg amputation</a></li><li><a class='rsswidget' href='https://www.theregional.com/parks-canada-offers-its-safety-message-for-jasper-ab/'>Parks Canada offers its safety message for Jasper AB</a></li><li><a class='rsswidget' href='https://www.theregional.com/alberta-county-councillor-makes-prank-freedom-convoy-donation/'>Alberta county councillor makes ‘prank’ Freedom Convoy donation</a></li><li><a class='rsswidget' href='https://www.theregional.com/new-nova-scotia-rental-rules-change-little-for-tourism-operators/'>Nova Scotia rental rules change little for tourism operators</a></li><li><a class='rsswidget' href='https://www.theregional.com/dozens-in-puvirnituq-nvt-take-challenge-to-get-sober/'>Dozens in Puvirnituq NVT take challenge to get sober</a></li><li><a class='rsswidget' href='https://www.theregional.com/alberta-mp-shields-continues-fight-to-protect-local-newspapers/'>Alberta MP Shields continues fight to protect local newspapers</a></li><li><a class='rsswidget' href='https://www.theregional.com/swan-hill-ab-snowmobilers-itching-for-season-start/'>Swan Hill AB snowmobilers itching for season start</a></li><li><a class='rsswidget' href='https://www.theregional.com/french-immersion-school-in-niverville-mb-possible/'>French immersion school in Niverville MB possible</a></li></ul></aside><aside id="ajdg_grpwidgets-4" class="widget ajdg_grpwidgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside>			</div>

			<div class="footer-column footer-column-3">
				<aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://quirknews.com/" target="_blank" rel="noopener"><img src="https://southpeacenews.com/wp-content/uploads/2017/01/QuirkNewsButton.png" alt="click this button to go to QuirkNews.com">
	Click above to go to QuirkNews.com</a></center>
<iframe style="border: 3px solid black" src="https://quirknews.com/quirk-links/" width="420" height="700" frameborder="0" allowfullscreen="allowfullscreen"></iframe></div></aside>			</div>

			<div class="footer-column footer-column-4">
				<aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/laughgen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/quotegen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside>			</div>

		<div id="site-bottom" class="clearfix">

				<div class="copyright"><div class="left">&copy; 2022 <a href="https://www.southpeacenews.com" title="" rel="home"></a>. All rights reserved.</div><div class="right">Built by South Peace News</div></div><!-- .copyright -->

		</div>

	</footer><!-- #colophon -->
	
</div><!-- #page -->

    <!-- LikeBtn.com BEGIN -->
    <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>
    <!-- LikeBtn.com END -->
            <!-- Custom Facebook Feed JS -->
<script type="text/javascript">var cffajaxurl = "https://www.southpeacenews.com/wp-admin/admin-ajax.php";
var cfflinkhashtags = "true";
</script>
<script>document.documentElement.className = 'js';</script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://www.southpeacenews.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "4a10382c61", post_id : 53894 } ); } ); /* ]]> */</script>
<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1' id='awesome_weather-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/swv/js/index.js?ver=5.6.4' id='swv-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.southpeacenews.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.4' id='contact-form-7-js'></script>
<script type='text/javascript' id='rss-feed-pro-js-extra'>
/* <![CDATA[ */
var rssfp_object = {"url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/rss-feed-pro/assets/js/rss-feed-pro.js?ver=1.0.0' id='rss-feed-pro-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","top_ten_id":"53894","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"523033339"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=3.2.1' id='tptn_tracker-js'></script>
<script type='text/javascript' id='rss-retriever-ajax-js-extra'>
/* <![CDATA[ */
var rss_retriever = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-rss-retriever/inc/js/rss-retriever-ajax.js?ver=1.6.5' id='rss-retriever-ajax-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/js/freshlife.min.js' id='freshlife-scripts-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/comment-reply.min.js?ver=6.1.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/custom-facebook-feed/assets/js/cff-scripts.min.js?ver=4.1.5' id='cffscripts-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.6' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE&#038;ver=3.0' id='google-recaptcha-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/modules/recaptcha/index.js?ver=5.6.4' id='wpcf7-recaptcha-js'></script>
<script defer type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.12' id='akismet-form-js'></script>
	<script type="text/javascript">

		$(document).ready(function(){
			$('#primary-menu').slicknav({
				prependTo:'#primary-bar',
				label: "PAGES"
			});
			$('#secondary-menu').slicknav({
				prependTo:'#secondary-bar',
				label: "CATEGORIES"
			});
		});

	</script>
	<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-2').gslider({groupid:2,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-4').gslider({groupid:4,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-5').gslider({groupid:5,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-7').gslider({groupid:7,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-8').gslider({groupid:8,speed:4000,repeat_impressions:'Y'});
	jQuery('.g-9').gslider({groupid:9,speed:7000,repeat_impressions:'Y'});
	jQuery('.g-10').gslider({groupid:10,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-11').gslider({groupid:11,speed:3000,repeat_impressions:'Y'});
	jQuery('.g-14').gslider({groupid:14,speed:12000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->


</body>
</html>