<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.southpeacenews.com/xmlrpc.php">


<title>Obituary - Levis Joseph Pelletier |</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.southpeacenews.com/pelletier-levis-joseph/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Obituary - Levis Joseph Pelletier |" />
<meta property="og:url" content="http://www.southpeacenews.com/pelletier-levis-joseph/" />
<meta property="article:published_time" content="2020-09-09T00:26:43+00:00" />
<meta property="article:modified_time" content="2020-09-09T00:28:50+00:00" />
<meta property="og:image" content="https://www.southpeacenews.com/wp-content/uploads/2020/09/PelletierPic.png" />
<meta property="og:image:width" content="263" />
<meta property="og:image:height" content="274" />
<meta name="twitter:card" content="summary_large_image" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.southpeacenews.com/#website","url":"https://www.southpeacenews.com/","name":"","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.southpeacenews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://www.southpeacenews.com/pelletier-levis-joseph/#primaryimage","inLanguage":"en-US","url":"https://www.southpeacenews.com/wp-content/uploads/2020/09/PelletierPic.png","width":263,"height":274},{"@type":"WebPage","@id":"http://www.southpeacenews.com/pelletier-levis-joseph/#webpage","url":"http://www.southpeacenews.com/pelletier-levis-joseph/","name":"Obituary - Levis Joseph Pelletier |","isPartOf":{"@id":"https://www.southpeacenews.com/#website"},"primaryImageOfPage":{"@id":"http://www.southpeacenews.com/pelletier-levis-joseph/#primaryimage"},"datePublished":"2020-09-09T00:26:43+00:00","dateModified":"2020-09-09T00:28:50+00:00","author":{"@id":"https://www.southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://www.southpeacenews.com/pelletier-levis-joseph/"]}]},{"@type":"Person","@id":"https://www.southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14","name":"Admin2015"}]}</script>

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://www.southpeacenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://www.southpeacenews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Obituary &#8211; Levis Joseph Pelletier Comments Feed" href="https://www.southpeacenews.com/pelletier-levis-joseph/feed/" />
<link href="https://southpeacenews.com/wp-content/uploads/2017/09/SPN_logo_no_bg.png" rel="icon">
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.southpeacenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.southpeacenews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css' href='https://www.southpeacenews.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=5.5.1' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-style-css' href='https://www.southpeacenews.com/wp-content/plugins/comments-widget-plus/assets/css/cwp.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css' href='https://www.southpeacenews.com/wp-content/plugins/custom-facebook-feed/css/cff-style.css?ver=2.16.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='likebtn_style-css' href='https://www.southpeacenews.com/wp-content/plugins/likebtn-like-button/public/css/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='tptn-style-left-thumbs-css' href='https://www.southpeacenews.com/wp-content/plugins/top-10/css/default-style.css?ver=1.0' type='text/css' media='all' />
<style id='tptn-style-left-thumbs-inline-css' type='text/css'>

img.tptn_thumb {
  width: 150px !important;
  height: 150px !important;
}
                

			.tptn_posts_widget2 img.tptn_thumb {
				width: 64px !important;
				height: 64px !important;
			}
			
</style>
<link rel='stylesheet' id='parent-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-plugins-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/css/plugins.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/style.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-responsive-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/css/responsive.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-child-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.southpeacenews.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.12' type='text/css' media='all' />
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' id='likebtn_frontend-js-extra'>
/* <![CDATA[ */
var likebtn_eh_data = {"ajaxurl":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","security":"8b3b7d88b8"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=5.5.1' id='likebtn_frontend-js'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/js/html5shiv.min.js' id='freshlife-html5-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-image-zoooom/assets/js/jquery.image_zoom.min.js?ver=1.43' id='image_zoooom-js'></script>
<script type='text/javascript' id='image_zoooom-init-js-extra'>
/* <![CDATA[ */
var IZ = {"with_woocommerce":"0","exchange_thumbnails":"1","woo_categories":"0","enable_mobile":"","options":{"lensShape":"square","zoomType":"lens","lensSize":400,"borderSize":1,"borderColour":"#ffffff","cursor":"zoom-in","lensFadeIn":0.5,"lensFadeOut":0.5,"tint":"true","tintColour":"#ffffff","tintOpacity":0.1000000000000000055511151231257827021181583404541015625},"woo_slider":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-image-zoooom/assets/js/image_zoom-init.js?ver=1.43' id='image_zoooom-init-js'></script>
<link rel="https://api.w.org/" href="https://www.southpeacenews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.southpeacenews.com/wp-json/wp/v2/posts/35382" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.southpeacenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.southpeacenews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://www.southpeacenews.com/?p=35382' />
<link rel="alternate" type="application/json+oembed" href="https://www.southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-3 { margin:0px width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-3 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-8 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-9 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:184px; }
	.g-10 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:500px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<style type="text/css">.cwp-li {overflow: hidden;}.cwp-avatar {float: left;margin-top: .2em;margin-right: 1em;}.cwp-avatar.rounded .avatar{border-radius:50%;}.cwp-avatar.square .avatar{border-radius:0;}.cwp-comment-excerpt {display: block;color:#787878;}</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #173191; }
</style>

<style>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</style>

<style>

		#primary-nav ul li a:hover, 		 
		#primary-nav ul li.current-menu-item a,
		#secondary-nav ul li a:hover,
		#secondary-nav ul li.current-menu-item a,
                .pagination .page-numbers.current { 
			background-color: #2266bb;
		}

		a:link,
		a:visited,		
		.widget_tabs .tab-content .entry-title a:hover,
		#site-bottom a:hover,
		.category-box ul li strong a:hover,
		.section-title a:hover,
		.widget_latest_comments a:hover .name,
		.related-posts ul li a:hover .entry-title,
		.widget_tabs .tab-content ul li .entry-title:hover,
		.widget_tabs #tab3 li a span:hover,
 		#secondary-nav ul.sf-menu li li a:hover,
		#primary-nav ul.sf-menu li li a:hover,
		#secondary-nav .sf-menu li li a:hover
		.posts .cat-posts .view-more a,
		.posts .cat-posts a:hover .entry-title,
		.header-social a .fa,
		.posts .sub-cats li:hover > a:after,
		.single .entry-meta .entry-author a:hover,
                .pagination .page-numbers {
			color: #2266bb;
		}

		#secondary-nav .sf-mega {
			border-top: 3px solid #2266bb;
		}

		#secondary-bar {
			border-bottom: 3px solid #2266bb;
		}

		.widget_tabs .tabs-nav li.active a,
		.widget_tabs .tabs-nav li a.selected,
		.widget_tabs .tabs-nav li a:hover {
			background-color: #48d;
		}

		.widget_tabs .tabs-nav li a,
                .author-bio {
			background-color: #eef5ff;
		}

		.widget_tabs .tabs-nav {
			border-bottom: 3px solid #48d;
		}

	</style>
<script src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE'></script>
</head>
<body class="post-template-default single single-post postid-35382 single-format-standard custom-background group-blog content-sidebar layout-content-sidebar" itemscope itemtype="http://schema.org/Blog">
<div align="center">
<a href="https://www.southpeacenews.com"><img src="http://southpeacenews.com/wp-content/uploads/2017/02/SPN_WebBanner2017.png" /></a></div>
<div id="page" class="container hfeed site clearfix">
<header id="masthead" class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div id="primary-bar">
<nav id="primary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul id="primary-menu" class="primary-menu sf-menu"><li id="menu-item-25482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25482"><a href="http://southpeacenews.com/">Home</a></li>
<li id="menu-item-21754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21754"><a target="_blank" href="http://citylive.com/submitted-by-readers">Submit News</a></li>
<li id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-97"><a href="https://www.southpeacenews.com/ads/">Notices / Employment / ETC.</a>
<ul class="sub-menu">
<li id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90"><a href="https://www.southpeacenews.com/sales/">ADS Sales</a></li>
<li id="menu-item-98" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98"><a href="https://www.southpeacenews.com/notices/">ADS Notices</a></li>
<li id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://www.southpeacenews.com/employment/">ADS Employment</a></li>
<li id="menu-item-89" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89"><a href="https://www.southpeacenews.com/services/">ADS Services</a></li>
<li id="menu-item-93" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93"><a href="https://www.southpeacenews.com/general/">ADS General</a></li>
<li id="menu-item-13201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13201"><a href="https://www.southpeacenews.com/promo-items/">ADS SPN Promotional Page</a></li>
</ul>
</li>
<li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92"><a href="https://www.southpeacenews.com/horoscopes/">Horoscopes</a></li>
<li id="menu-item-18637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18637"><a target="_blank" href="http://classified.citylive.com/">Classifieds</a></li>
</ul>
</nav>
<div class="header-search">
<form method="get" class="searchform" id="search-form" action="https://www.southpeacenews.com/" role="search">
<input type="search" class="search-field field" placeholder="Press enter to search &hellip;" value="" name="s" title="Search for:" />
<button name="search" id="search"><i class="fa fa-search"></i></button>
</form>
</div>
</div>
<div class="site-branding clearfix">
<div id="logo">
<h1 class="site-title" itemprop="headline"><a href="https://www.southpeacenews.com" itemprop="url" rel="home"><span itemprop="headline"></span></a></h1>
<h2 class="site-description" itemprop="description"></h2></div>
<div id="header-widget-area" class="chw-widget-area widget-area" role="complementary">
<div class="chw-widget"></div> </div>
<div style="margin-bottom: 5px;">
<div class="g g-9"><div class="g-dyn a-932 c-1"><a class="gofollow" data-track="OTMyLDksMSw2MA==" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/08/WhitefishLakeFN_StoreManager_dblTOP.png" /></a></div></div></div>
<div style="margin-bottom: 5px;">
</div>
</div>
<div id="secondary-bar" class="clearfix">
<nav id="secondary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul id="secondary-menu" class="secondary-menu sf-menu"><li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-47"><a href="https://www.southpeacenews.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://www.southpeacenews.com/category/councils/">Councils</a></li>
<li id="menu-item-15686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15686"><a href="https://www.southpeacenews.com/category/news/schools/">Schools</a></li>
<li id="menu-item-28794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28794"><a href="https://www.southpeacenews.com/category/news/court-docket/">Court Docket</a></li>
<li id="menu-item-32254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32254"><a href="https://www.southpeacenews.com/category/news/the-page/">THE PAGE</a></li>
</ul>
</li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.southpeacenews.com/category/sports/">Sports</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55"><a href="https://www.southpeacenews.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-14593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14593"><a href="https://www.southpeacenews.com/category/opinion/polls/">Polls</a></li>
</ul>
</li>
<li id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="https://www.southpeacenews.com/category/events/">Events</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54"><a href="https://www.southpeacenews.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-32219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-32219"><a href="https://www.southpeacenews.com/category/extras/">EXTRAS</a>
<ul class="sub-menu">
<li id="menu-item-31450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31450"><a href="https://www.southpeacenews.com/kids-talk/">Kids&#8217; Talk</a></li>
<li id="menu-item-32220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32220"><a href="https://www.southpeacenews.com/category/extras/inspirations/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-27004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27004"><a href="https://www.southpeacenews.com/category/today-in-hp/">Today in HP</a></li>
<li id="menu-item-32208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32208"><a target="_blank" href="https://www.southpeacenews.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-32222" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32222"><a href="https://www.southpeacenews.com/select-contest/">SELECT Tool of the Week Contest</a></li>
</ul>
</nav>
</div>
</header>
<div id="site-content" class="site-content">
<main id="main" class="site-main clearfix" role="main" class="content">
<div id="primary" class="content-area">
<div id="content" class="single">
<div id="breadcrumbs">
<div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><span class="trail-begin"><a href="https://www.southpeacenews.com" title="" rel="home">Home</a></span>
<span class="sep"><i class="fa fa-caret-right"></i></span> <a href="https://www.southpeacenews.com/category/obituaries/" rel="tag">Obituaries</a>
<span class="sep"><i class="fa fa-caret-right"></i></span> <span class="trail-end">Obituary &#8211; Levis Joseph Pelletier</span>
</div>
</div>
<article id="post-35382" class="post-35382 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost">
<header class="entry-header">
<h1 class="page-title" itemprop="headline">Obituary &#8211; Levis Joseph Pelletier</h1>
<div class="entry-meta">
<span class="entry-date">
<time class="published" datetime="2020-09-08T18:26:43-06:00" itemprop="datePublished">September 8, 2020</time>
</span>
<span class="sep">&#183;</span>
by
<span class="entry-author author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a class="url fn n" href="https://www.southpeacenews.com/author/admin2015/" itemprop="url"><span itemprop="name">Admin2015</span></a></span>
<span class="sep">&#183;</span>
<span class="entry-comments"><i class="fa fa-comment-o"></i> <a href="https://www.southpeacenews.com/pelletier-levis-joseph/#respond" itemprop="discussionURL">0</a></span>
</div>
</header>
<div class="entry-content" itemprop="articleBody">
<figure class="wp-block-image size-large is-resized is-style-default"><img loading="lazy" src="https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-839x1260.png" alt="" class="wp-image-35374" width="839" height="1260" srcset="https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-839x1260.png 839w, https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-100x150.png 100w, https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-43x64.png 43w, https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-768x1153.png 768w, https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-1023x1536.png 1023w, https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier-1364x2048.png 1364w, https://www.southpeacenews.com/wp-content/uploads/2020/09/OBIT_LevisPelletier.png 2000w" sizes="(max-width: 839px) 100vw, 839px" /></figure>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3165736599172791" data-ad-slot="6075938174" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<footer class="entry-footer">
<span class="entry-cats"><strong>Filed in:</strong> <a href="https://www.southpeacenews.com/category/obituaries/" rel="category tag">Obituaries</a></span>
</footer>
<div class="clearfix"></div>
<div class="entry-share clearfix">
<h3>Share this post</h3>
<ul>
<li class="twitter"><a href="https://twitter.com/intent/tweet?text=Obituary &#8211; Levis Joseph Pelletier&url=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F" target="_blank"><i class="fa fa-twitter"></i>Twitter</a></li>
<li class="facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F" target="_blank"><i class="fa fa-facebook"></i>Facebook</a></li>
<li class="google-plus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F" target="_blank"><i class="fa fa-google-plus"></i>Google+</a></li>
<li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F&title=Obituary &#8211; Levis Joseph Pelletier" target="_blank"><i class="fa fa-linkedin"></i>LinkedIn</a></li>
<li class="pinterest"><a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.southpeacenews.com%2Fpelletier-levis-joseph%2F&media=https%3A%2F%2Fwww.southpeacenews.com%2Fwp-content%2Fuploads%2F2020%2F09%2FPelletierPic.png" target="_blank"><i class="fa fa-pinterest"></i>Pinterest</a></li>
<li class="email"><a href="mailto:"><i class="fa fa-envelope-o"></i>Email</a></li>
</ul>
</div>
<div class="related-posts">
<h3>Recommended for You</h3>
<ul class="clearfix">
<li>
<a href="https://www.southpeacenews.com/obituary-ethel-helma-kuefler/">
<img width="200" height="113" src="https://www.southpeacenews.com/wp-content/uploads/2020/08/Obituary-Ethel-Kuefler-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Obituary &#8211; Ethel Helma Kuefler" loading="lazy" itemprop="image" /> <h2 class="entry-title">Obituary &#8211; Ethel Helma Kuefler</h2> </a>
</li>
<li>
<a href="https://www.southpeacenews.com/obituary-madeleine-marie-nee-brochu-hebert/">
<img width="200" height="113" src="https://www.southpeacenews.com/wp-content/uploads/2020/08/Obituary-Madeleine-Hebert-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Obituary &#8211; Madeleine Marie [née Brochu] Hébert" loading="lazy" itemprop="image" /> <h2 class="entry-title">Obituary &#8211; Madeleine Marie [née Brochu] Hébert</h2> </a>
</li>
<li>
<a href="https://www.southpeacenews.com/obituary-leonard-milbert-burback/">
<img width="200" height="113" src="https://www.southpeacenews.com/wp-content/uploads/2020/08/Obituary-Leonard-Burback-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Obituary &#8211; Leonard Milbert Burback" loading="lazy" itemprop="image" /> <h2 class="entry-title">Obituary &#8211; Leonard Milbert Burback</h2> </a>
</li>
<li>
<a href="https://www.southpeacenews.com/obituary-lorraine-d-jaeger/">
<img width="200" height="113" src="https://www.southpeacenews.com/wp-content/uploads/2020/08/Obituary-Jaeger-Lorraine-200x113.jpg" class="attachment-freshlife-related size-freshlife-related wp-post-image" alt="Obituary &#8211; Lorraine D. Jaeger" loading="lazy" itemprop="image" /> <h2 class="entry-title">Obituary &#8211; Lorraine D. Jaeger</h2> </a>
</li>
</ul>
</div>
</article>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Post Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/pelletier-levis-joseph/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.southpeacenews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author"> Name <span class="required">*</span></label> <input class="txt" id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email"> Email <span class="required">*</span></label> <input class="txt" id="email" name="email" type="email" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url"> Website</label> <input class="txt" id="url" name="url" type="url" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='35382' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8dab52f87b" /></p><input class="btn" name="submit" type="submit" id="submit" value="Post Comment" /><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="187" /></p></form> </div>
</div>
</div>
</div>
<div id="secondary" class="widget-area widget-primary sidebar" role="complementary" aria-label="Primary Sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://highprairie.citylive.com/hp-events-calendar/" target="_blank" rel="noopener noreferrer"><img src="http://highprairie.com/wp-content/uploads/2016/11/Calendar_Small_Banner.png" alt="click for the High Prairie & Area Events Calendar"></a>
</div></aside><aside id="ajdg_grpwidgets-2" class="widget ajdg_grpwidgets"><div class="g g-1"><div class="g-dyn a-852 c-1"><a class="gofollow" data-track="ODUyLDEsMSw2MA==" href="https://southpeacenews.com/select-contest/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Select_TooloftheWeek_SIDE.png" /></a></div><div class="g-dyn a-639 c-2"><a class="gofollow" data-track="NjM5LDEsMSw2MA==" href="http://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_SIDE.png" /></a></div><div class="g-dyn a-930 c-3"><a class="gofollow" data-track="OTMwLDEsMSw2MA==" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/08/WhitefishLakeFN_StoreManager_SIDE.png" /></a></div><div class="g-dyn a-65 c-4"><a class="gofollow" data-track="NjUsMSwxLDYw" href="http://southpeacenews.com/contact/"><img src="http://southpeacenews.com/wp-content/uploads/2016/10/WeWantNews_side_png.png" /></a></div><div class="g-dyn a-803 c-5"><a class="gofollow" data-track="ODAzLDEsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_SIDE.png" /></a></div><div class="g-dyn a-846 c-6"><a class="gofollow" data-track="ODQ2LDEsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2020/02/ChurchDirectory_SIDE.png" /></a></div></div></aside><aside id="awesomeweatherwidget-4" class="widget widget_awesomeweatherwidget"><div id="awe-ajax-awesome-weather-peace-river-ab" class="awe-ajax-awesome-weather-peace-river-ab awe-weather-ajax-wrap" style=""><div class="awe-loading"><i class="wi wi-day-sunny"></i></div></div><script type="text/javascript"> jQuery(document).ready(function() { awe_ajax_load({"id":"awesome-weather-peace-river-ab","locale":"","location":"PEACE RIVER AB","owm_city_id":"6100069","override_title":"HIGH PRAIRIE - PEACE RIVER ","size":"wide","units":"C","forecast_days":"10","hide_stats":0,"show_link":0,"background":"","custom_bg_color":"","use_user_location":0,"allow_user_to_change":0,"show_icons":0,"extended_url":"","extended_text":"","background_by_weather":1,"text_color":"#eeee22","hide_attribution":1,"skip_geolocate":0,"latlng":"","ajaxurl":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","via_ajax":1}); }); </script></aside><aside id="text-2" class="widget widget_text"> <div class="textwidget"><center><p><a href="https://weather.gc.ca/city/pages/ab-25_metric_e.html"><img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif" < img> Environment Canada Forecast <img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif" < img></a></p><p><a href="https://511.alberta.ca/map#:Alerts"><img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif" < img> Alberta 511 Road Reports <img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif" < a></P>
<p><a href="http://www.emergencyalert.alberta.ca/"><img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png" < img> Alberta Wildfire Status Map <img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png" < img></a></p></center></div>
</aside><aside id="cwp-widget-2" class="widget widget_recent_comments comments_widget_plus"><h3 class="widget-title">Recent Comments</h3><ul class="cwp-ul "><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/pic-happy-retirement/#comment-8966"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Arnold</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/pic-happy-retirement/#comment-8966">PIC &#8211; Happy retirement!</a></span><span class="comment-excerpt cwp-comment-excerpt">Congratulations Pat &amp; Sheila, Eleanor and Arnold are right behind you!! Rememb&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/man-barred-from-high-prairie-bar-for-one-year/#comment-8788"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Ben Dover</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/man-barred-from-high-prairie-bar-for-one-year/#comment-8788">Man barred from High Prairie bar for one year</a></span><span class="comment-excerpt cwp-comment-excerpt">What do felons Halcrow, Auger and Thunder have in common?</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/mitchell-named-new-nlc-president/#comment-8787"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">K. Bains</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/mitchell-named-new-nlc-president/#comment-8787">Mitchell named new NLC president</a></span><span class="comment-excerpt cwp-comment-excerpt">Mitchell will have Vandermeulen bullying his every move.</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/obituary-gayso-matula/#comment-8759"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Karolina Olsavska</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/obituary-gayso-matula/#comment-8759">Obituary &#8211; Gayso Matula</a></span><span class="comment-excerpt cwp-comment-excerpt">We will never forget Gayso. He visited our family in Slovakia in August 1987. We w&hellip;</span></li></ul></aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><h3 class="widget-title">Your Thoughts Are Welcome</h3><div class="textwidget custom-html-widget">Comments for particular stories should go on the comment section below that story. General comments submit <a href="http://southpeacenews.com/general-comments/">HERE</a></div></aside><aside id="ajdg_grpwidgets-3" class="widget ajdg_grpwidgets"><div class="g g-10"><div class="g-dyn a-931 c-1"><a class="gofollow" data-track="OTMxLDEwLDEsNjA=" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/08/WhitefishLakeFN_StoreManager_dblSIDE.png" /></a></div></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://quirknews.com/" target="_blank" rel="noopener noreferrer"><img src="https://southpeacenews.com/wp-content/uploads/2017/01/QuirkNewsButton.png" alt="click this button to go to QuirkNews.com">
Click above to go to QuirkNews.com</a></center>
<iframe style="border: 3px solid black" src="https://quirknews.com/quirk-links/" width="420" height="500" frameborder="0" allowfullscreen="allowfullscreen"></iframe></div></aside><aside id="widget_tptn_pop-2" class="widget tptn_posts_list_widget"><h3 class="widget-title">&#8212;&#8212; MOST READ STORIES &#8211; PAST 14 DAYS &#8212;&#8212;</h3><div class="tptn_posts_daily  tptn_posts_widget tptn_posts_widget2"><ul><li><a href="https://www.southpeacenews.com/drug-charges-laid-after-police-pursuit-at-driftpile/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Drug charges laid after police pursuit at Driftpile" title="Drug charges laid after police pursuit at Driftpile" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/drug-charges-laid-after-police-pursuit-at-driftpile/" class="tptn_link"><span class="tptn_title">Drug charges laid after police pursuit at Driftpile</span></a><span class="tptn_excerpt"> Chris CleggSouth Peace News An adult male and adult female face drug charges after an arrest on the&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-august-27-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – August 27, 2020" title="COVID-19 UPDATE – August 27, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-august-27-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – August 27, 2020</span></a><span class="tptn_excerpt"> As of August 27, Alberta Health has confirmed 312 new cases in Alberta in the last 72 hours.&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/pic-driver-injured/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/08/26aug20_pic1a-64x64.jpg" class="tptn_thumb tptn_featured" alt="PIC - Driver injured" title="PIC - Driver injured" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/pic-driver-injured/" class="tptn_link"><span class="tptn_title">PIC &#8211; Driver injured</span></a><span class="tptn_excerpt"> The driver of a car involved in a single-vehicle accident Aug. 17 was taken to hospital for treatment.&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-august-31-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – August 31, 2020" title="COVID-19 UPDATE – August 31, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-august-31-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – August 31, 2020</span></a><span class="tptn_excerpt"> As of August 31, Alberta Health has confirmed 584 new cases in Alberta in the last 96 hours.&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-september-4-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – September 4, 2020" title="COVID-19 UPDATE – September 4, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-september-4-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – September 4, 2020</span></a><span class="tptn_excerpt"> As of September 4, Alberta Health has confirmed 164 new cases in Alberta in the last 24 hours.&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/attempted-theft-ends-badly-for-victim/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Attempted theft ends badly for victim" title="Attempted theft ends badly for victim" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/attempted-theft-ends-badly-for-victim/" class="tptn_link"><span class="tptn_title">Attempted theft ends badly for victim</span></a><span class="tptn_excerpt"> Chris CleggSouth Peace News A man ended up in policy custody after he flipped the semi-truck he stole&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-victim-visited-prjh-school-delayed/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="COVID victim visited PRJH; school delayed" title="COVID victim visited PRJH; school delayed" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-victim-visited-prjh-school-delayed/" class="tptn_link"><span class="tptn_title">COVID victim visited PRJH; school delayed</span></a><span class="tptn_excerpt"> Chris Clegg South Peace News Students at Prairie River Junior High School do not have to return to&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/man-threatens-to-kill-spouse-and-self/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Man threatens to kill spouse and self" title="Man threatens to kill spouse and self" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/man-threatens-to-kill-spouse-and-self/" class="tptn_link"><span class="tptn_title">Man threatens to kill spouse and self</span></a><span class="tptn_excerpt"> H.P. court docketJudge D.R. ShynkarAug. 24, 2020 Kendell Sawan, 28, of Peace River, was sentenced to probation for&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/judge-suspends-woman-from-driving-for-2-years/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Judge suspends woman from driving for 2 years" title="Judge suspends woman from driving for 2 years" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/judge-suspends-woman-from-driving-for-2-years/" class="tptn_link"><span class="tptn_title">Judge suspends woman from driving for 2 years</span></a><span class="tptn_excerpt"> H.P. court docketAug. 17, 2020Judge M.B. Golden A middle-age woman will be off the road for a couple&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-september-3-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – September 3, 2020" title="COVID-19 UPDATE – September 3, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-september-3-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – September 3, 2020</span></a><span class="tptn_excerpt"> As of September 3, Alberta Health has confirmed 408 new cases in Alberta in the last 72 hours.&hellip;</span></span></li></ul><div class="tptn_clear"></div></div></aside><aside id="ajdg_grpwidgets-11" class="widget ajdg_grpwidgets"><div class="g g-3"><div class="g-dyn a-803 c-1"><a class="gofollow" data-track="ODAzLDMsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_SIDE.png" /></a></div><div class="g-dyn a-852 c-2"><a class="gofollow" data-track="ODUyLDMsMSw2MA==" href="https://southpeacenews.com/select-contest/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Select_TooloftheWeek_SIDE.png" /></a></div><div class="g-dyn a-930 c-3"><a class="gofollow" data-track="OTMwLDMsMSw2MA==" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/08/WhitefishLakeFN_StoreManager_SIDE.png" /></a></div><div class="g-dyn a-639 c-4"><a class="gofollow" data-track="NjM5LDMsMSw2MA==" href="http://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_SIDE.png" /></a></div><div class="g-dyn a-846 c-5"><a class="gofollow" data-track="ODQ2LDMsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2020/02/ChurchDirectory_SIDE.png" /></a></div></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3165736599172791" data-ad-slot="6075938174" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside></div>
</main>
</div>
<div class="clearfix"></div>
<footer id="footer" class="site-footer clearfix" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="footer-column footer-column-1">
<aside id="text-4" class="widget widget_text"><h3 class="widget-title">SUPPORT INFORMATION</h3> <div class="textwidget"><p><a href="https://southpeacenews.com/get-alerts/">Sign Up for Email Alerts</a><br />
<a href="http://southpeacenews.com/contact/">Contact Us</a><br />
<a href="http://southpeacenews.com/about/">About The South Peace News</a><br />
<a href="http://southpeacenews.com/advertising-rates/">Online Advertising Rates</a></p>
</div>
</aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">ARCHIVES</h3> <label class="screen-reader-text" for="archives-dropdown-2">ARCHIVES</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.southpeacenews.com/2020/09/'> September 2020 &nbsp;(34)</option>
<option value='https://www.southpeacenews.com/2020/08/'> August 2020 &nbsp;(121)</option>
<option value='https://www.southpeacenews.com/2020/07/'> July 2020 &nbsp;(148)</option>
<option value='https://www.southpeacenews.com/2020/06/'> June 2020 &nbsp;(180)</option>
<option value='https://www.southpeacenews.com/2020/05/'> May 2020 &nbsp;(182)</option>
<option value='https://www.southpeacenews.com/2020/04/'> April 2020 &nbsp;(219)</option>
<option value='https://www.southpeacenews.com/2020/03/'> March 2020 &nbsp;(216)</option>
<option value='https://www.southpeacenews.com/2020/02/'> February 2020 &nbsp;(123)</option>
<option value='https://www.southpeacenews.com/2020/01/'> January 2020 &nbsp;(146)</option>
<option value='https://www.southpeacenews.com/2019/12/'> December 2019 &nbsp;(152)</option>
<option value='https://www.southpeacenews.com/2019/11/'> November 2019 &nbsp;(147)</option>
<option value='https://www.southpeacenews.com/2019/10/'> October 2019 &nbsp;(182)</option>
<option value='https://www.southpeacenews.com/2019/09/'> September 2019 &nbsp;(143)</option>
<option value='https://www.southpeacenews.com/2019/08/'> August 2019 &nbsp;(109)</option>
<option value='https://www.southpeacenews.com/2019/07/'> July 2019 &nbsp;(179)</option>
<option value='https://www.southpeacenews.com/2019/06/'> June 2019 &nbsp;(148)</option>
<option value='https://www.southpeacenews.com/2019/05/'> May 2019 &nbsp;(135)</option>
<option value='https://www.southpeacenews.com/2019/04/'> April 2019 &nbsp;(156)</option>
<option value='https://www.southpeacenews.com/2019/03/'> March 2019 &nbsp;(117)</option>
<option value='https://www.southpeacenews.com/2019/02/'> February 2019 &nbsp;(75)</option>
<option value='https://www.southpeacenews.com/2019/01/'> January 2019 &nbsp;(128)</option>
<option value='https://www.southpeacenews.com/2018/12/'> December 2018 &nbsp;(90)</option>
<option value='https://www.southpeacenews.com/2018/11/'> November 2018 &nbsp;(141)</option>
<option value='https://www.southpeacenews.com/2018/10/'> October 2018 &nbsp;(133)</option>
<option value='https://www.southpeacenews.com/2018/09/'> September 2018 &nbsp;(111)</option>
<option value='https://www.southpeacenews.com/2018/08/'> August 2018 &nbsp;(108)</option>
<option value='https://www.southpeacenews.com/2018/07/'> July 2018 &nbsp;(152)</option>
<option value='https://www.southpeacenews.com/2018/06/'> June 2018 &nbsp;(120)</option>
<option value='https://www.southpeacenews.com/2018/05/'> May 2018 &nbsp;(138)</option>
<option value='https://www.southpeacenews.com/2018/04/'> April 2018 &nbsp;(135)</option>
<option value='https://www.southpeacenews.com/2018/03/'> March 2018 &nbsp;(151)</option>
<option value='https://www.southpeacenews.com/2018/02/'> February 2018 &nbsp;(134)</option>
<option value='https://www.southpeacenews.com/2018/01/'> January 2018 &nbsp;(119)</option>
<option value='https://www.southpeacenews.com/2017/12/'> December 2017 &nbsp;(133)</option>
<option value='https://www.southpeacenews.com/2017/11/'> November 2017 &nbsp;(140)</option>
<option value='https://www.southpeacenews.com/2017/10/'> October 2017 &nbsp;(152)</option>
<option value='https://www.southpeacenews.com/2017/09/'> September 2017 &nbsp;(130)</option>
<option value='https://www.southpeacenews.com/2017/08/'> August 2017 &nbsp;(113)</option>
<option value='https://www.southpeacenews.com/2017/07/'> July 2017 &nbsp;(138)</option>
<option value='https://www.southpeacenews.com/2017/06/'> June 2017 &nbsp;(153)</option>
<option value='https://www.southpeacenews.com/2017/05/'> May 2017 &nbsp;(159)</option>
<option value='https://www.southpeacenews.com/2017/04/'> April 2017 &nbsp;(144)</option>
<option value='https://www.southpeacenews.com/2017/03/'> March 2017 &nbsp;(142)</option>
<option value='https://www.southpeacenews.com/2017/02/'> February 2017 &nbsp;(118)</option>
<option value='https://www.southpeacenews.com/2017/01/'> January 2017 &nbsp;(117)</option>
<option value='https://www.southpeacenews.com/2016/12/'> December 2016 &nbsp;(151)</option>
<option value='https://www.southpeacenews.com/2016/11/'> November 2016 &nbsp;(136)</option>
<option value='https://www.southpeacenews.com/2016/10/'> October 2016 &nbsp;(178)</option>
<option value='https://www.southpeacenews.com/2016/09/'> September 2016 &nbsp;(154)</option>
<option value='https://www.southpeacenews.com/2016/08/'> August 2016 &nbsp;(147)</option>
<option value='https://www.southpeacenews.com/2016/07/'> July 2016 &nbsp;(153)</option>
<option value='https://www.southpeacenews.com/2016/06/'> June 2016 &nbsp;(172)</option>
<option value='https://www.southpeacenews.com/2016/05/'> May 2016 &nbsp;(159)</option>
<option value='https://www.southpeacenews.com/2016/04/'> April 2016 &nbsp;(73)</option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</aside><aside id="text-10" class="widget widget_text"><h3 class="widget-title">PURLS To Brighten Your Day</h3> <div class="textwidget"><p>Advertiser Sale of The Week &#8211; Coming<br />
Recipe &#8211; Coming<br />
Canada Home of The Week &#8211; Coming<br />
Coffee Break &#8211; Coming<br />
Top Headline &#8211; Coming</p>
<p>&nbsp;</p>
</div>
</aside> </div>
<div class="footer-column footer-column-2">
<aside id="ajdg_grpwidgets-4" class="widget ajdg_grpwidgets"><div class="g g-6"><div class="g-dyn a-65 c-1"><a class="gofollow" data-track="NjUsNiwxLDYw" href="http://southpeacenews.com/contact/"><img src="http://southpeacenews.com/wp-content/uploads/2016/10/WeWantNews_side_png.png" /></a></div></div></aside> </div>
<div class="footer-column footer-column-3">
<aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/quotegen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside> </div>
<div class="footer-column footer-column-4">
<aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/laughgen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside> </div>
<div id="site-bottom" class="clearfix">
<div class="copyright"><div class="left">&copy; 2020 <a href="https://www.southpeacenews.com" title="" rel="home"></a>. All rights reserved.</div><div class="right">Built by South Peace News</div></div>
</div>
</footer>
</div>

<script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>


<script type="text/javascript">
var cfflinkhashtags = "true";
</script>
<script>document.documentElement.className = 'js';</script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://www.southpeacenews.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "2bbbd4b117", post_id : 35382 } ); } ); /* ]]> */</script>
<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1' id='awesome_weather-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.southpeacenews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/custom-facebook-feed/js/cff-scripts.js?ver=2.16.1' id='cffscripts-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","top_ten_id":"35382","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"1008084650"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0' id='tptn_tracker-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE&#038;ver=3.0' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js?ver=5.2.2' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/js/freshlife.min.js' id='freshlife-scripts-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/comment-reply.min.js?ver=5.5.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.4' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type="text/javascript">

		$(document).ready(function(){
			$('#primary-menu').slicknav({
				prependTo:'#primary-bar',
				label: "PAGES"
			});
			$('#secondary-menu').slicknav({
				prependTo:'#secondary-bar',
				label: "CATEGORIES"
			});
		});

	</script>

<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-2').gslider({groupid:2,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-4').gslider({groupid:4,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-5').gslider({groupid:5,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:7000,repeat_impressions:'Y'});
	jQuery('.g-7').gslider({groupid:7,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-8').gslider({groupid:8,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-9').gslider({groupid:9,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-10').gslider({groupid:10,speed:6000,repeat_impressions:'Y'});
}});
</script>

</body>
</html>