<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.southpeacenews.com/xmlrpc.php">


<title>Today in High Prairie - December 20, 2020 |</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.southpeacenews.com/today-in-high-prairie-december-20-2020/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Today in High Prairie - December 20, 2020 |" />
<meta property="og:description" content="Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history and your daily horoscope. Please send your birthdays and community events to southpeacenews@hotmail.com and statsmanchris@hotmail.com What’s Happening Today – December 20, 2020 No listings! Today’s Local Birthdays – High Prairie – December 20, 2020 Kamoule Sharkawi Marvin&hellip;" />
<meta property="og:url" content="http://www.southpeacenews.com/today-in-high-prairie-december-20-2020/" />
<meta property="article:published_time" content="2020-12-19T22:19:51+00:00" />
<meta property="article:modified_time" content="2020-12-19T22:19:55+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Admin2015">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="7 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.southpeacenews.com/#website","url":"http://www.southpeacenews.com/","name":"","description":"","potentialAction":[{"@type":"SearchAction","target":"http://www.southpeacenews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"http://www.southpeacenews.com/today-in-high-prairie-december-20-2020/#webpage","url":"http://www.southpeacenews.com/today-in-high-prairie-december-20-2020/","name":"Today in High Prairie - December 20, 2020 |","isPartOf":{"@id":"http://www.southpeacenews.com/#website"},"datePublished":"2020-12-19T22:19:51+00:00","dateModified":"2020-12-19T22:19:55+00:00","author":{"@id":"http://www.southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://www.southpeacenews.com/today-in-high-prairie-december-20-2020/"]}]},{"@type":"Person","@id":"http://www.southpeacenews.com/#/schema/person/4d917d33c9e3122eb41d63de9a587e14","name":"Admin2015"}]}</script>

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://www.southpeacenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://www.southpeacenews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Today in High Prairie &#8211; December 20, 2020 Comments Feed" href="https://www.southpeacenews.com/today-in-high-prairie-december-20-2020/feed/" />
<link href="https://southpeacenews.com/wp-content/uploads/2017/09/SPN_logo_no_bg.png" rel="icon">
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.southpeacenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.southpeacenews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css' href='https://www.southpeacenews.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=5.6' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-style-css' href='https://www.southpeacenews.com/wp-content/plugins/comments-widget-plus/assets/css/cwp.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css' href='https://www.southpeacenews.com/wp-content/plugins/custom-facebook-feed/css/cff-style.css?ver=2.17.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='likebtn_style-css' href='https://www.southpeacenews.com/wp-content/plugins/likebtn-like-button/public/css/style.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='colorboxstyle-css' href='https://www.southpeacenews.com/wp-content/plugins/modal-dialog/colorbox/colorbox.css?ver=1.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='tptn-style-left-thumbs-css' href='https://www.southpeacenews.com/wp-content/plugins/top-10/css/default-style.css?ver=1.0' type='text/css' media='all' />
<style id='tptn-style-left-thumbs-inline-css' type='text/css'>

img.tptn_thumb {
  width: 150px !important;
  height: 150px !important;
}
                

			.tptn_posts_widget2 img.tptn_thumb {
				width: 64px !important;
				height: 64px !important;
			}
			
</style>
<link rel='stylesheet' id='parent-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/style.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-plugins-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/css/plugins.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-responsive-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/css/responsive.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='freshlife-child-style-css' href='https://www.southpeacenews.com/wp-content/themes/freshlife-child/style.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.southpeacenews.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.12' type='text/css' media='all' />
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='likebtn_frontend-js-extra'>
/* <![CDATA[ */
var likebtn_eh_data = {"ajaxurl":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","security":"0b2d4fe97a"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=5.6' id='likebtn_frontend-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/modal-dialog/cookie.js?ver=1.0' id='jquerycookies-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/modal-dialog/colorbox/jquery.colorbox-min.js?ver=1.5.6' id='colorboxpack-js'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/js/html5shiv.min.js' id='freshlife-html5-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-image-zoooom/assets/js/jquery.image_zoom.min.js?ver=1.44' id='image_zoooom-js'></script>
<script type='text/javascript' id='image_zoooom-init-js-extra'>
/* <![CDATA[ */
var IZ = {"with_woocommerce":"0","exchange_thumbnails":"1","woo_categories":"0","enable_mobile":"","options":{"lensShape":"square","zoomType":"lens","lensSize":400,"borderSize":1,"borderColour":"#ffffff","cursor":"zoom-in","lensFadeIn":0.5,"lensFadeOut":0.5,"tint":"true","tintColour":"#ffffff","tintOpacity":0.1000000000000000055511151231257827021181583404541015625},"woo_slider":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/wp-image-zoooom/assets/js/image_zoom-init.js?ver=1.44' id='image_zoooom-init-js'></script>
<link rel="https://api.w.org/" href="https://www.southpeacenews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.southpeacenews.com/wp-json/wp/v2/posts/38147" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.southpeacenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.southpeacenews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://www.southpeacenews.com/?p=38147' />
<link rel="alternate" type="application/json+oembed" href="https://www.southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.southpeacenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-3 { margin:0px width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-6 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-4 { margin:0px 0px 0px 0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-8 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-9 { margin:0px 0px 0px 0px; width:100%; max-width:728px; height:100%; max-height:184px; }
	.g-10 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:500px; }
	.g-11 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<style type="text/css">.cwp-li {overflow: hidden;}.cwp-avatar {float: left;margin-top: .2em;margin-right: 1em;}.cwp-avatar.rounded .avatar{border-radius:50%;}.cwp-avatar.square .avatar{border-radius:0;}.cwp-comment-excerpt {display: block;color:#787878;}</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #173191; }
</style>

<style>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</style>

<style>

		#primary-nav ul li a:hover, 		 
		#primary-nav ul li.current-menu-item a,
		#secondary-nav ul li a:hover,
		#secondary-nav ul li.current-menu-item a,
                .pagination .page-numbers.current { 
			background-color: #2266bb;
		}

		a:link,
		a:visited,		
		.widget_tabs .tab-content .entry-title a:hover,
		#site-bottom a:hover,
		.category-box ul li strong a:hover,
		.section-title a:hover,
		.widget_latest_comments a:hover .name,
		.related-posts ul li a:hover .entry-title,
		.widget_tabs .tab-content ul li .entry-title:hover,
		.widget_tabs #tab3 li a span:hover,
 		#secondary-nav ul.sf-menu li li a:hover,
		#primary-nav ul.sf-menu li li a:hover,
		#secondary-nav .sf-menu li li a:hover
		.posts .cat-posts .view-more a,
		.posts .cat-posts a:hover .entry-title,
		.header-social a .fa,
		.posts .sub-cats li:hover > a:after,
		.single .entry-meta .entry-author a:hover,
                .pagination .page-numbers {
			color: #2266bb;
		}

		#secondary-nav .sf-mega {
			border-top: 3px solid #2266bb;
		}

		#secondary-bar {
			border-bottom: 3px solid #2266bb;
		}

		.widget_tabs .tabs-nav li.active a,
		.widget_tabs .tabs-nav li a.selected,
		.widget_tabs .tabs-nav li a:hover {
			background-color: #48d;
		}

		.widget_tabs .tabs-nav li a,
                .author-bio {
			background-color: #eef5ff;
		}

		.widget_tabs .tabs-nav {
			border-bottom: 3px solid #48d;
		}

	</style>
<script src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE'></script>
</head>
<body class="post-template-default single single-post postid-38147 single-format-standard custom-background group-blog content-sidebar layout-content-sidebar" itemscope itemtype="http://schema.org/Blog">
<div align="center">
<a href="https://www.southpeacenews.com"><img src="http://southpeacenews.com/wp-content/uploads/2017/02/SPN_WebBanner2017.png" /></a></div>
<div id="page" class="container hfeed site clearfix">
<header id="masthead" class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div id="primary-bar">
<nav id="primary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul id="primary-menu" class="primary-menu sf-menu"><li id="menu-item-25482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25482"><a href="http://southpeacenews.com/">Home</a></li>
<li id="menu-item-21754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21754"><a target="_blank" href="http://citylive.com/submitted-by-readers">Submit News</a></li>
<li id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-97"><a href="https://www.southpeacenews.com/ads/">Notices / Employment / ETC.</a>
<ul class="sub-menu">
<li id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90"><a href="https://www.southpeacenews.com/sales/">ADS Sales</a></li>
<li id="menu-item-98" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98"><a href="https://www.southpeacenews.com/notices/">ADS Notices</a></li>
<li id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://www.southpeacenews.com/employment/">ADS Employment</a></li>
<li id="menu-item-89" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89"><a href="https://www.southpeacenews.com/services/">ADS Services</a></li>
<li id="menu-item-93" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93"><a href="https://www.southpeacenews.com/general/">ADS General</a></li>
<li id="menu-item-13201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13201"><a href="https://www.southpeacenews.com/promo-items/">ADS SPN Promotional Page</a></li>
</ul>
</li>
<li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92"><a href="https://www.southpeacenews.com/horoscopes/">Horoscopes</a></li>
<li id="menu-item-18637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18637"><a target="_blank" href="http://classified.citylive.com/">Classifieds</a></li>
</ul>
</nav>
<div class="header-search">
<form method="get" class="searchform" id="search-form" action="https://www.southpeacenews.com/" role="search">
<input type="search" class="search-field field" placeholder="Press enter to search &hellip;" value="" name="s" title="Search for:" />
<button name="search" id="search"><i class="fa fa-search"></i></button>
</form>
</div>
</div>
<div class="site-branding clearfix">
<div id="logo">
<h1 class="site-title" itemprop="headline"><a href="https://www.southpeacenews.com" itemprop="url" rel="home"><span itemprop="headline"></span></a></h1>
<h2 class="site-description" itemprop="description"></h2></div>
<div id="header-widget-area" class="chw-widget-area widget-area" role="complementary">
<div class="chw-widget"><div class="g g-8"><div class="g-dyn a-1112 c-1"><a class="gofollow" data-track="MTExMiw4LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/2PRSchoolDivision_CG_SIDE.png" /></a></div><div class="g-dyn a-1113 c-2"><a class="gofollow" data-track="MTExMyw4LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPMedicalClinic_CG_SIDE.png" /></a></div><div class="g-dyn a-1116 c-3"><a class="gofollow" data-track="MTExNiw4LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/SPN_CG_SIDE.png" /></a></div><div class="g-dyn a-1117 c-4"><a class="gofollow" data-track="MTExNyw4LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HolidayGreetings_SIDE.png" /></a></div></div></div> </div>
<div style="margin-bottom: 5px;">
<div class="g g-9"><div class="g-dyn a-883 c-1"><a class="gofollow" data-track="ODgzLDksMSw2MA==" href="https://southpeacenews.com/notices/"><img src="http://southpeacenews.com/wp-content/uploads/2020/05/AreYouAnArtist_DBL.png"></a></div><div class="g-dyn a-983 c-2"><a class="gofollow" data-track="OTgzLDksMSw2MA==" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/HPSD1_dblTOP.png" /></a></div><div class="g-dyn a-1090 c-3"><a class="gofollow" data-track="MTA5MCw5LDEsNjA=" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPAgSociety_EmployOpp_dblTOP.png" /></a></div><div class="g-dyn a-1078 c-4"><a class="gofollow" data-track="MTA3OCw5LDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/Marigold_CookieBoxes_dblTOP.png" /></a></div><div class="g-dyn a-1096 c-5"><a class="gofollow" data-track="MTA5Niw5LDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/Marigolds_HolidayHours_dblTOP.png" /></a></div><div class="g-dyn a-1100 c-6"><a class="gofollow" data-track="MTEwMCw5LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/AprilIsidore_VOTE_dblTOP.png" /></a></div><div class="g-dyn a-1110 c-7"><a class="gofollow" data-track="MTExMCw5LDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/A1_hours_dblTOP.png" /></a></div><div class="g-dyn a-1106 c-8"><a class="gofollow" data-track="MTEwNiw5LDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/GlamourGear_BoxingDay_dblTOP.png" /></a></div><div class="g-dyn a-1008 c-9"><a class="gofollow" data-track="MTAwOCw5LDEsNjA=" href="https://www.southpeacenews.com/contact/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/BusinessDirectory_dblTOP.png" /></a></div><div class="g-dyn a-1086 c-10"><a class="gofollow" data-track="MTA4Niw5LDEsNjA=" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/GlamourGear_HolidayHours_dblTOP.png" /></a></div><div class="g-dyn a-1082 c-11"><a class="gofollow" data-track="MTA4Miw5LDEsNjA=" href="https://www.southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/HagenBisonRanch_dblTOP.png" /></a></div></div></div>
<div style="margin-bottom: 5px;">
</div>
</div>
<div id="secondary-bar" class="clearfix">
<nav id="secondary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<ul id="secondary-menu" class="secondary-menu sf-menu"><li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-47"><a href="https://www.southpeacenews.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://www.southpeacenews.com/category/councils/">Councils</a></li>
<li id="menu-item-15686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15686"><a href="https://www.southpeacenews.com/category/news/schools/">Schools</a></li>
<li id="menu-item-28794" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28794"><a href="https://www.southpeacenews.com/category/news/court-docket/">Court Docket</a></li>
<li id="menu-item-32254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32254"><a href="https://www.southpeacenews.com/category/news/the-page/">THE PAGE</a></li>
</ul>
</li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.southpeacenews.com/category/sports/">Sports</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55"><a href="https://www.southpeacenews.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-14593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14593"><a href="https://www.southpeacenews.com/category/opinion/polls/">Polls</a></li>
</ul>
</li>
<li id="menu-item-58" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58"><a href="https://www.southpeacenews.com/category/events/">Events</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.southpeacenews.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-32219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-32219"><a href="https://www.southpeacenews.com/category/extras/">EXTRAS</a>
<ul class="sub-menu">
<li id="menu-item-31450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31450"><a href="https://www.southpeacenews.com/kids-talk/">Kids&#8217; Talk</a></li>
<li id="menu-item-32220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32220"><a href="https://www.southpeacenews.com/category/extras/inspirations/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-27004" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27004"><a href="https://www.southpeacenews.com/category/today-in-hp/">Today in HP</a></li>
<li id="menu-item-32208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32208"><a target="_blank" href="https://www.southpeacenews.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-32222" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32222"><a href="https://www.southpeacenews.com/select-contest/">SELECT Tool of the Week Contest</a></li>
</ul>
</nav>
</div>
</header>
<div id="site-content" class="site-content">
<main id="main" class="site-main clearfix" role="main" class="content">
<div id="primary" class="content-area">
<div id="content" class="single">
<div id="breadcrumbs">
<div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><span class="trail-begin"><a href="https://www.southpeacenews.com" title="" rel="home">Home</a></span>
<span class="sep"><i class="fa fa-caret-right"></i></span> <a href="https://www.southpeacenews.com/category/today-in-hp/" rel="tag">Today in HP</a>
<span class="sep"><i class="fa fa-caret-right"></i></span> <span class="trail-end">Today in High Prairie &#8211; December 20, 2020</span>
</div>
</div>
<article id="post-38147" class="post-38147 post type-post status-publish format-standard hentry category-today-in-hp no-post-thumbnail entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost">
<header class="entry-header">
<h1 class="page-title" itemprop="headline">Today in High Prairie &#8211; December 20, 2020</h1>
<div class="entry-meta">
<span class="entry-date">
<time class="published" datetime="2020-12-19T15:19:51-07:00" itemprop="datePublished">December 19, 2020</time>
</span>
<span class="sep">&#183;</span>
by
<span class="entry-author author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a class="url fn n" href="https://www.southpeacenews.com/author/admin2015/" itemprop="url"><span itemprop="name">Admin2015</span></a></span>
<span class="sep">&#183;</span>
<span class="entry-comments"><i class="fa fa-comment-o"></i> <a href="https://www.southpeacenews.com/today-in-high-prairie-december-20-2020/#respond" itemprop="discussionURL">0</a></span>
</div>
</header>
<div class="entry-content" itemprop="articleBody">
<p>Today in High Prairie! See what’s happening today in town, local birthdays, celebrity birthdays, local history, world history and your daily horoscope. Please send your birthdays and community events to <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="ef9c809a9b879f8a8e8c8a818a989caf87809b828e8683c18c8082">[email&#160;protected]</a> and <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1360677267607e727d707b617a60537b7c677e727a7f3d707c7e">[email&#160;protected]</a></p>
<p>What’s Happening Today – December 20, 2020</p>
<p>No listings!</p>
<p>Today’s Local Birthdays – High Prairie – December 20, 2020</p>
<p>Kamoule Sharkawi</p>
<p>Marvin Williscroft</p>
<p>Today’s Local Birthdays – Faust – December 20, 2020</p>
<p>Apryl Nygaard</p>
<p>Candace Courtoreille</p>
<p>Sage Chalifoux</p>
<p>Valla Sinclair</p>
<p>Today’s Celebrity Birthdays – December 20, 2020</p>
<p>1865 &#8211; Maude Gonne, “Irish Joan of Arc”</p>
<p>1868 &#8211; Harvey Firestone, Firestone Tire Founder</p>
<p>1869 &#8211; Charlie Grapewin, Wizard of Oz Actor</p>
<p>1898 &#8211; Irene Dunne, Cimarron Actress</p>
<p>1922 &#8211; Charita Bauer, Aldrich Family Actress</p>
<p>1932 &#8211; John Hillerman, Magnum PI Actor</p>
<p>1939 &#8211; Kathryn Joosten, Desperate Housewives Actress</p>
<p>1940 &#8211; Larry Willis, Blood, Sweat &amp; Tears Rocker</p>
<p>1944 &#8211; Robert Colomby, Blood, Sweat &amp; Tears Drummer</p>
<p>1945 &#8211; Peter Criss, KISS Drummer</p>
<p>1946 &#8211; John Spencer, LA Law Actor</p>
<p>1946 &#8211; Dick Wolf, Law &amp; Order Creator</p>
<p>1948 &#8211; Alan Parsons, Alan Parson Project Leader</p>
<p>1956 &#8211; Guy Babylon, Elton John Keayboardist</p>
<p>1963 &#8211; Karen Moncrieff, Days of Our Lives Actress</p>
<p>1977 – Saukrates, Canadian Rapper</p>
<p>1983 &#8211; Jonah Hill, Wolf of Wall Street Actor</p>
<p>This Day in Local History – December 20, 2020</p>
<p>Dec. 20, 1913: The Grouard News reports trains arrive within 10 miles of Mirror Landing.</p>
<p>Dec. 20, 1913: The Grouard News reports that the health officer prohibits the sale of ice taken from the river and Buffalo Bay citing its impurity.</p>
<p>Dec. 20, 1914: Joseph Shaw, age six months, dies after being scalded by a pot of boiling water on Dec. 10. Mrs. Bottle tipped the pot while putting wood in the stove.</p>
<p>Dec. 20, 1930: Cyril Porter is the first postmaster as the Leicester [Peavine] post office opens.</p>
<p>Dec. 20, 1950: Dr. John B.T. Wood resigns as MLA for the Grouard constituency.</p>
<p>Dec. 20, 1974: Fred Abbott, director of the High Prairie Information Centre, resigns after it is announced the centre will not be receiving money from Lesser Slave Lake Preventive Social Services after March 31, 1975.</p>
<p>Dec. 20, 1978: South Peace News reports that Dan Vandermeulen says that the Jackpines should be preserved as a wilderness area.</p>
<p>Dec. 20, 1980: Kelly Halcrow, Kenny Lalonde and Lyle Halcrow win gold medals at the Alberta Bronze Gloves Boxing Tournament in Fort Saskatchewan.</p>
<p>Dec. 20, 1981: Sid Cook, of Faust, accumulates the most points at snow drag races held in Valleyview.</p>
<p>Dec. 20, 1990: Keith Calahasen and Chris Keay are promoted to World Taekwondo Federation First Black Belt.</p>
<p>Dec. 20, 1999: A boy, 16, pleads guilty to assault with a weapon in High Prairie youth court after shooting a 10-year-old girl in the leg with a pellet gun. He was ordered to complete 15 hours of community service work.</p>
<p>Dec. 20, 2005: Mary Diane Adams passes away from cancer at the age of 68 years.</p>
<p>Dec. 20, 2010: The Town of High Prairie’s new electronic sign is installed. It is expected to be ready for use in days.</p>
<p>Dec. 20, 2013: Leonarda’s Beauty Salon closes ending a 52-year run. Owner Helen Henderson’s efforts to sell the business were unsuccessful.</p>
<p>Dec. 20, 2016: The High Prairie Community Beautification Association receives a $19,800 Community Facility Enhancement Program grant to upgrade MacIntyre Park.</p>
<p>Dec. 20-21, 2016: Santa’s Little Helpers volunteers prepare 19 Christmas hampers at the High Prairie and District Children’s Resource Council.</p>
<p>Dec. 20-21, 2017: Santa’s Little Helper distributes 34 Christmas hampers to needy families in the region. Last year, only 19 were delivered.</p>
<p>Dec. 20, 2018: The High Prairie and District Children’s Resource Council distributes 39 Christmas hampers to families in the region.</p>
<p>This Day in World History – December 20, 2020</p>
<p>1192&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Richard the Lionhearted captured in Vienna.</p>
<p>1606&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Settlers leave London to establish Jamestown, Virginia.</p>
<p>1699&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Peter the Great orders New Year changed to Jan. 1 [from Sept. 1].</p>
<p>1812&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; “Grimm’s Fairy Tales” by Jacob Grimm and Wilhelm Grimm published.</p>
<p>1820&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Missouri imposes a $1 bachelor tax on unmarried men 21-50.</p>
<p>1879&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Thomas Edison privately demonstrates incandescent light.</p>
<p>1891&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Strongman Louis Cyr withstands pull of 4 horses.</p>
<p>1892&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Pneumatic automobile tire patented.</p>
<p>1900&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Giacobini discovers a comet [1st comet visited by spacecraft].</p>
<p>1919&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Canadian National Railways established.</p>
<p>1922&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 14 republics form USSR.</p>
<p>1924&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Adolf Hitler freed from jail early: 9 months of 5-year sentence.</p>
<p>1928&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 1st international dogsled mail leaves Minot, Maine for Montreal.</p>
<p>1939&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Radio Australia begins overseas shortwave service.</p>
<p>1945&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Rationing of auto tires ends in US.</p>
<p>1946&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Christmas classic “It’s a Wonderful Life” film premieres.</p>
<p>1951&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 1st nuclear reactor to produce electric power goes live.</p>
<p>1955&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Cardiff is proclaimed the capital city of Wales.</p>
<p>1957&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Elvis Presley receives his draft notice to join the US Army.</p>
<p>1960&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Viet Cong is officially formed in South Vietnam.</p>
<p>1963&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Berlin Wall opens for 1st time to West Berliners.</p>
<p>1963&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Trial against 21 camp guards of Auschwitz begins.</p>
<p>1967&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Report: 474,300 US soldiers in Vietnam.</p>
<p>1976&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Israeli PM Yitzhak Rabin resigns.</p>
<p>1977&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 1st space walk made by Soviet cosmonaut Georgy Grechko.</p>
<p>1980&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; NBC broadcasts NY Jets’ 24-17 win over Dolphins without audio.</p>
<p>1983&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Guy Lafleur, Montreal, became 10th NHLer to score 500 goals.</p>
<p>1984&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 33 unknown Bach keyboard works found in Yale library.</p>
<p>1985&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Sportscaster Howard Cosell retires from TV sports.</p>
<p>1990&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; The world’s first website and server go live at CERN.</p>
<p>1999&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Portugal returns Macau to China.</p>
<p>2007&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Queen Elizabeth II, 81, becomes oldest ever monarch of UK.</p>
<p>2012&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Apple is denied a patent for mobile pinch-to-zoom gestures.</p>
<p>2017&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Lady Gaga signs Las Vegas residency deal for $75 million at MGM.</p>
<p>2018&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Report: stats show average US male is 198 lbs, females 171 lbs.</p>
<p>Today’s Horoscopes – December 20, 2020</p>
<p>Cancer [June 22 – July 22] – You like to give people advice and help them find direction in their lives &#8211; sometimes when they haven’t even asked. But now it’s your turn to feel a little lost. You may need to get away from it all to get some perspective on your life. What about taking a trip to some faraway land? Today is a good day to make your future vacation plans.</p>
<p>Leo [July 23 – Aug. 23] – You may put your integrity under the microscope today. We all have deep convictions that we would never let go of. But society pressures us, and it isn’t always easy to live in perfect harmony with our ideals. The question to ask yourself today is just how willing are you to change your most heartfelt beliefs in order to live in society? Do you have the courage of your convictions?</p>
<p>Virgo [Aug. 24 – Sept. 22] – Your freedom is more important to you than anything else in your life. It’s often very difficult for you to get involved, whether personally or professionally. Nevertheless, today you may have to think about it. Could it be that your thirst for freedom is just an escape? You may need to ponder this question. Who knows? You could decide to take the leap!</p>
<p>Libra [Sept. 23 – Oct. 23] – Certain very narrow-minded people may get on your nerves. You’re lucky enough to be an open, tolerant person. You take people and situations just as they come. Today you may find yourself in the middle of negotiations between two people with opposite views. Help them open their eyes to each other’s point of view.</p>
<p>Scorpio [Oct. 24 – Nov. 22] – Today you will be able to explore the power of your emotions. Don’t try and fight what you call your “oversensitivity.” A force from childhood will permeate you and help you to find out what your real needs are. Shouldn’t you think about staying away from people who influence you a little too much? Think about it and go with your emotions.</p>
<p>Sagittarius [Nov. 23 – Dec. 21] – You feel secure in the warmth and depth of your emotions. Today you will have the opportunity to reenergize and regenerate yourself from the inside out. Take advantage of the energies at play to deepen your relationships with the people you love. Get to know them even better. Your powers of seduction will mesmerize them.</p>
<p>Capricorn [Dec. 22 – Jan. 20] – The atmosphere may seem a bit oppressive today. You like to be free to do what you want to do, and it may bother you the people around you don’t make themselves available to you. They seem preoccupied by their own business. This could bring out some old wounds that haven’t completely healed.</p>
<p>Aquarius [Jan. 21 – Feb. 18] – You may feel a bit tied down today. It won’t necessarily be a bad day, but you may wonder about certain aspects of your family life. Don’t try and kid yourself. You should think hard about what you want for your family for the next few years and how you intend to go about getting it.</p>
<p>Pisces [Feb. 19 – March 20] – There are days when you should take everything with a grain of salt. Today you may realize how important it is to gain the appreciation and respect of a certain person. It isn’t worth getting worked up about. You will only make things worse. You may just need to do something that puts the fire back into your emotions.</p>
<p>Aries [March 21 – April 20] – You shouldn’t even try to find a reasonable explanation for what goes on around you today. There isn’t one. Be carried by the tides of emotions from the past that run through your body and soul. There’s no use trying to control them &#8211; they need to come out. Instead, take the time to revitalize yourself in the intimacy of your home or at a friend’s, if possible.</p>
<p>Taurus [April 21 – May 21] – Today you may ask yourself if you’re satisfied. How is your personal life? Do people live up to your standards or are you always left feeling dissatisfied? It may be time to make some important decisions in your life. What do you really want out of life? You might find some of the answers today.</p>
<p>Gemini [May 22 – June 21] – Nothing is simple where your family is concerned. If you’ve forgotten that, don’t worry. Today will remind you. You may have to deal with some of your lingering problems with certain family members. You will find you have all the energy you need in order to find the solutions to the conflicts that have been eating at you for a while.</p>
<p></p>
<div class="likebtn_container" style="clear:both;text-align:center;"><span class="likebtn-wrapper" data-identifier="post_38147" data-site_id="5a85da066fd08b8d780a138a" data-theme="large" data-ef_voting="heartbeat" data-show_dislike_label="true" data-counter_type="percent" data-voting_frequency="604800" data-white_label="true" data-rich_snippet="true" data-i18n_like="This informed me" data-i18n_dislike="This not needed" data-i18n_after_like="Liked" data-i18n_after_dislike="Disliked" data-i18n_like_tooltip="I found the content of this post interesting" data-i18n_dislike_tooltip="This post did not interest me" data-i18n_unlike_tooltip="I liked this already" data-i18n_undislike_tooltip="I disliked this already" data-style="" data-unlike_allowed="" data-show_copyright="" data-item_url="https://www.southpeacenews.com/today-in-high-prairie-december-20-2020/" data-item_title="Today in High Prairie - December 20, 2020" data-item_date="2020-12-19T15:19:51-07:00" data-engine="WordPress" data-plugin_v="2.6.29" data-prx="https://www.southpeacenews.com/wp-admin/admin-ajax.php?action=likebtn_prx" data-event_handler="likebtn_eh"></span></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3165736599172791" data-ad-slot="6075938174" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<footer class="entry-footer">
<span class="entry-cats"><strong>Filed in:</strong> <a href="https://www.southpeacenews.com/category/today-in-hp/" rel="category tag">Today in HP</a></span>
</footer>
<div class="clearfix"></div>
<div class="entry-share clearfix">
<h3>Share this post</h3>
<ul>
<li class="twitter"><a href="https://twitter.com/intent/tweet?text=Today in High Prairie &#8211; December 20, 2020&url=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F" target="_blank"><i class="fa fa-twitter"></i>Twitter</a></li>
<li class="facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F" target="_blank"><i class="fa fa-facebook"></i>Facebook</a></li>
<li class="google-plus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F" target="_blank"><i class="fa fa-google-plus"></i>Google+</a></li>
<li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F&title=Today in High Prairie &#8211; December 20, 2020" target="_blank"><i class="fa fa-linkedin"></i>LinkedIn</a></li>
<li class="pinterest"><a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.southpeacenews.com%2Ftoday-in-high-prairie-december-20-2020%2F&media=" target="_blank"><i class="fa fa-pinterest"></i>Pinterest</a></li>
<li class="email"><a href="mailto:"><i class="fa fa-envelope-o"></i>Email</a></li>
</ul>
</div>
<div class="related-posts">
<h3>Recommended for You</h3>
<ul class="clearfix">
<li>
<a href="https://www.southpeacenews.com/today-in-high-prairie-december-19-2020/">
<h2 class="entry-title">Today in High Prairie – December 19, 2020</h2> </a>
</li>
<li>
<a href="https://www.southpeacenews.com/today-in-high-prairie-december-18-2020/">
<h2 class="entry-title">Today in High Prairie &#8211; December 18, 2020</h2> </a>
</li>
<li>
<a href="https://www.southpeacenews.com/today-in-high-prairie-december-17-2020/">
<h2 class="entry-title">Today in High Prairie &#8211; December 17, 2020</h2> </a>
</li>
<li>
<a href="https://www.southpeacenews.com/today-in-high-prairie-december-16-2020/">
<h2 class="entry-title">Today in High Prairie &#8211; December 16, 2020</h2> </a>
</li>
</ul>
</div>
</article>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Post Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/today-in-high-prairie-december-20-2020/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.southpeacenews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author"> Name <span class="required">*</span></label> <input class="txt" id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email"> Email <span class="required">*</span></label> <input class="txt" id="email" name="email" type="email" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url"> Website</label> <input class="txt" id="url" name="url" type="url" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='38147' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a90e931f13" /></p><input class="btn" name="submit" type="submit" id="submit" value="Post Comment" /><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="38" /></p></form> </div>
</div>
</div>
</div>
<div id="secondary" class="widget-area widget-primary sidebar" role="complementary" aria-label="Primary Sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://highprairie.citylive.com/hp-events-calendar/" target="_blank" rel="noopener"><img src="http://highprairie.com/wp-content/uploads/2016/11/Calendar_Small_Banner.png" alt="click for the High Prairie & Area Events Calendar"></a>
</div></aside><aside id="ajdg_grpwidgets-2" class="widget ajdg_grpwidgets"><div class="g g-1"><div class="g-dyn a-857 c-1"><a class="gofollow" data-track="ODU3LDEsMSw2MA==" href="http://classified.citylive.com/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Classifieds1_SIDE.png" /></a></div><div class="g-dyn a-998 c-2"><a class="gofollow" data-track="OTk4LDEsMSw2MA==" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/HPSD1_SIDE.png" /></a></div><div class="g-dyn a-1081 c-3"><a class="gofollow" data-track="MTA4MSwxLDEsNjA=" href="https://www.southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/HagenBisonRanch_SIDE.png" /></a></div><div class="g-dyn a-1085 c-4"><a class="gofollow" data-track="MTA4NSwxLDEsNjA=" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/GlamourGear_HolidayHours_SIDE.png" /></a></div><div class="g-dyn a-1098 c-5"><a class="gofollow" data-track="MTA5OCwxLDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/Marigolds_Hours1_SIDE.png" /></a></div><div class="g-dyn a-1092 c-6"><a class="gofollow" data-track="MTA5MiwxLDEsNjA=" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPAGSociety_Caretaker_SIDE.png" /></a></div><div class="g-dyn a-1118 c-7"><a class="gofollow" data-track="MTExOCwxLDEsNjA=" href="https://www.southpeacenews.com/get-alerts/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/SignUp_SIDE.png" /></a></div><div class="g-dyn a-1109 c-8"><a class="gofollow" data-track="MTEwOSwxLDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/A1_hours_SIDE.png" /></a></div><div class="g-dyn a-1077 c-9"><a class="gofollow" data-track="MTA3NywxLDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/Marigold_CookieBoxes_SIDE.png" /></a></div><div class="g-dyn a-639 c-10"><a class="gofollow" data-track="NjM5LDEsMSw2MA==" href="http://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_SIDE.png" /></a></div><div class="g-dyn a-852 c-11"><a class="gofollow" data-track="ODUyLDEsMSw2MA==" href="https://southpeacenews.com/select-contest/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Select_TooloftheWeek_SIDE.png" /></a></div><div class="g-dyn a-1101 c-12"><a class="gofollow" data-track="MTEwMSwxLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/AprilIsidore_VOTE_SIDE.png" /></a></div><div class="g-dyn a-1089 c-13"><a class="gofollow" data-track="MTA4OSwxLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/Marigold_FarmersMarket_SIDE.png" /></a></div><div class="g-dyn a-803 c-14"><a class="gofollow" data-track="ODAzLDEsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_SIDE.png" /></a></div><div class="g-dyn a-846 c-15"><a class="gofollow" data-track="ODQ2LDEsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2020/02/ChurchDirectory_SIDE.png" /></a></div><div class="g-dyn a-1006 c-16"><a class="gofollow" data-track="MTAwNiwxLDEsNjA=" href="http://southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/BusinessDirectory1_SIDE.png" /></a></div></div></aside><aside id="awesomeweatherwidget-4" class="widget widget_awesomeweatherwidget"><div id="awe-ajax-awesome-weather-peace-river-ab" class="awe-ajax-awesome-weather-peace-river-ab awe-weather-ajax-wrap" style=""><div class="awe-loading"><i class="wi wi-day-sunny"></i></div></div><script type="text/javascript"> jQuery(document).ready(function() { awe_ajax_load({"id":"awesome-weather-peace-river-ab","locale":"","location":"PEACE RIVER AB","owm_city_id":"6100069","override_title":"HIGH PRAIRIE - PEACE RIVER ","size":"wide","units":"C","forecast_days":"10","hide_stats":0,"show_link":0,"background":"","custom_bg_color":"","use_user_location":0,"allow_user_to_change":0,"show_icons":0,"extended_url":"","extended_text":"","background_by_weather":1,"text_color":"#eeee22","hide_attribution":1,"skip_geolocate":0,"latlng":"","ajaxurl":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","via_ajax":1}); }); </script></aside><aside id="text-2" class="widget widget_text"> <div class="textwidget"><center><p><a href="https://weather.gc.ca/city/pages/ab-25_metric_e.html"><img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif" < img> Environment Canada Forecast <img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/sun-1.gif" < img></a></p><p><a href="https://511.alberta.ca/map#:Alerts"><img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif" < img> Alberta 511 Road Reports <img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Snowflake.gif" < a></P>
<p><a href="http://www.emergencyalert.alberta.ca/"><img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png" < img> Alberta Wildfire Status Map <img src="http://smokyriverexpress.com/wp-content/uploads/2016/01/Fire.png" < img></a></p></center></div>
</aside><aside id="cwp-widget-2" class="widget widget_recent_comments comments_widget_plus"><h3 class="widget-title">Recent Comments</h3><ul class="cwp-ul "><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/driftpile-sucker-creek-settle/#comment-10324"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Ben Dover</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/driftpile-sucker-creek-settle/#comment-10324">Driftpile, Sucker Creek settle</a></span><span class="comment-excerpt cwp-comment-excerpt">This article lacked the dollar amount that only members recognized as this particu&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/bertie-celebrates-his-birthday-with-friends-at-park/#comment-10254"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Zyla H</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/bertie-celebrates-his-birthday-with-friends-at-park/#comment-10254">PICs &#8211; Bertie celebrates his birthday with friends at park</a></span><span class="comment-excerpt cwp-comment-excerpt">Hello! I am Zyla Halverson, I was 7 in that photo I am 9 now! I did have lots of q&hellip;</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/driftpile-sucker-creek-settle/#comment-10216"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">Bob Chalifoux</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/driftpile-sucker-creek-settle/#comment-10216">Driftpile, Sucker Creek settle</a></span><span class="comment-excerpt cwp-comment-excerpt">Ffs, couldn't you use "Agricultural Benefit Claim" !</span></li><li class="recentcomments cwp-li"><a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/commentary-why-is-mending-not-in-style/#comment-10163"><span class="comment-avatar cwp-avatar rounded"></span></a><span class="cwp-comment-title"><span class="comment-author-link cwp-author-link">At Home with Mend It Aussie</span> <span class="cwp-on-text">on</span> <a class="comment-link cwp-comment-link" href="https://www.southpeacenews.com/commentary-why-is-mending-not-in-style/#comment-10163">Commentary &#8211; Why is mending not in style?</a></span><span class="comment-excerpt cwp-comment-excerpt">Mending is trending and is better than ending and spending. Check out the hashtag&hellip;</span></li></ul></aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><h3 class="widget-title">Your Thoughts Are Welcome</h3><div class="textwidget custom-html-widget">Comments for particular stories should go on the comment section below that story. General comments submit <a href="http://southpeacenews.com/general-comments/">HERE</a></div></aside><aside id="ajdg_grpwidgets-3" class="widget ajdg_grpwidgets"><div class="g g-10"><div class="g-dyn a-1007 c-1"><a class="gofollow" data-track="MTAwNywxMCwxLDYw" href="http://southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/BusinessDirectory_dblSIDE.png" /></a></div><div class="g-dyn a-1087 c-2"><a class="gofollow" data-track="MTA4NywxMCwxLDYw" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/GlamourGear_Hours_dblSIDE.png" /></a></div><div class="g-dyn a-1095 c-3"><a class="gofollow" data-track="MTA5NSwxMCwxLDYw" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/Marigolds_Hours_dblSIDE.png" /></a></div><div class="g-dyn a-1099 c-4"><a class="gofollow" data-track="MTA5OSwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/AprilIsidore_VOTE_dblSIDE.png" /></a></div><div class="g-dyn a-1083 c-5"><a class="gofollow" data-track="MTA4MywxMCwxLDYw" href="https://www.southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/HagenBisonRanch_dblSIDE.png" /></a></div><div class="g-dyn a-984 c-6"><a class="gofollow" data-track="OTg0LDEwLDEsNjA=" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPSchoolDiv_Dec_dblSIDE.png" /></a></div><div class="g-dyn a-1091 c-7"><a class="gofollow" data-track="MTA5MSwxMCwxLDYw" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPAGSociety_Caretaker_dblSIDE.png" /></a></div><div class="g-dyn a-1115 c-8"><a class="gofollow" data-track="MTExNSwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/PRSchoolDivision_CG_dblSIDE.png" /></a></div><div class="g-dyn a-1104 c-9"><a class="gofollow" data-track="MTEwNCwxMCwxLDYw" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HagenBisonRanch_dblSIDE.png" /></a></div><div class="g-dyn a-1111 c-10"><a class="gofollow" data-track="MTExMSwxMCwxLDYw" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/A1_hours_dblSIDE.png" /></a></div><div class="g-dyn a-1114 c-11"><a class="gofollow" data-track="MTExNCwxMCwxLDYw" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPMedicalClinic_dblSIDE.png" /></a></div><div class="g-dyn a-1079 c-12"><a class="gofollow" data-track="MTA3OSwxMCwxLDYw" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/Marigold_CookieBoxes_dblSIDE.png" /></a></div><div class="g-dyn a-1107 c-13"><a class="gofollow" data-track="MTEwNywxMCwxLDYw" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/GlamourGear_BoxingDay_dblSIDE.png" /></a></div></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://quirknews.com/" target="_blank" rel="noopener"><img src="https://southpeacenews.com/wp-content/uploads/2017/01/QuirkNewsButton.png" alt="click this button to go to QuirkNews.com">
Click above to go to QuirkNews.com</a></center>
<iframe style="border: 3px solid black" src="https://quirknews.com/quirk-links/" width="420" height="500" frameborder="0" allowfullscreen="allowfullscreen"></iframe></div></aside><aside id="widget_tptn_pop-2" class="widget tptn_posts_list_widget"><h3 class="widget-title">&#8212;&#8212; MOST READ STORIES &#8211; PAST 14 DAYS &#8212;&#8212;</h3><div class="tptn_posts_daily  tptn_posts_widget tptn_posts_widget2"><ul><li><a href="https://www.southpeacenews.com/arson-charged-dropped-against-blackhurst-and-boy/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Arson charged dropped against Blackhurst and boy" title="Arson charged dropped against Blackhurst and boy" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/arson-charged-dropped-against-blackhurst-and-boy/" class="tptn_link"><span class="tptn_title">Arson charged dropped against Blackhurst and boy</span></a><span class="tptn_excerpt"> Richard Froese South Peace News Arson charges have been dropped against two young males charged in connection with&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-case-confirmed-at-high-prairie-st-andrews-school/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="COVID case confirmed at High Prairie St. Andrew&#039;s School" title="COVID case confirmed at High Prairie St. Andrew&#039;s School" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-case-confirmed-at-high-prairie-st-andrews-school/" class="tptn_link"><span class="tptn_title">COVID case confirmed at High Prairie St.&hellip;</span></a><span class="tptn_excerpt"> Editor’s note: The following letter was sent to the parents and guardians of High Prairie St. Andrew’s School&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/arrest-made-in-circle-k-atm-theft/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/12/9dec20_news1a-64x64.jpg" class="tptn_thumb tptn_featured" alt="Arrest made in Circle K ATM theft" title="Arrest made in Circle K ATM theft" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/arrest-made-in-circle-k-atm-theft/" class="tptn_link"><span class="tptn_title">Arrest made in Circle K ATM theft</span></a><span class="tptn_excerpt"> The aftermath of the ATM stolen at Circle K convenience store Nov. 21, 2019 is evident. The theft&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/driftpile-sucker-creek-settle/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Driftpile, Sucker Creek settle" title="Driftpile, Sucker Creek settle" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/driftpile-sucker-creek-settle/" class="tptn_link"><span class="tptn_title">Driftpile, Sucker Creek settle</span></a><span class="tptn_excerpt"> Band members receiving 'cows and plows' money Chris CleggSouth Peace News It took years of negotiations and many&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-december-11-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – December 11, 2020" title="COVID-19 UPDATE – December 11, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-december-11-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – December 11, 2020</span></a><span class="tptn_excerpt"> As of December 11, Alberta Health confirmed 1,738 new cases in Alberta since Dec 10. There are 303&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-december-9-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – December 9, 2020" title="COVID-19 UPDATE – December 9, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-december-9-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – December 9, 2020</span></a><span class="tptn_excerpt"> As of December 9, Alberta Health confirmed 1,460 new cases in Alberta since Dec 8. There are 107&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-update-december-7-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 UPDATE – December 7, 2020" title="COVID-19 UPDATE – December 7, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-update-december-7-2020/" class="tptn_link"><span class="tptn_title">COVID-19 UPDATE – December 7, 2020</span></a><span class="tptn_excerpt"> As of December 7, Alberta Health confirmed 5,450 new cases in Alberta since Dec 4. There are 330&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-mini-update-december-15-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 Mini-UPDATE – December 15, 2020" title="COVID-19 Mini-UPDATE – December 15, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-mini-update-december-15-2020/" class="tptn_link"><span class="tptn_title">COVID-19 Mini-UPDATE – December 15, 2020</span></a><span class="tptn_excerpt"> As of December 15, Alberta Health confirmed 1,341 new cases since Dec. 14. There are 123new cases in&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/man-fined-after-following-some-very-bad-advice/" class="tptn_link"><img width="64" height="64" src="https://southpeacenews.com/wp-content/plugins/top-10/default.png" class="tptn_thumb tptn_default_thumb" alt="Man fined after following some very bad advice" title="Man fined after following some very bad advice" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/man-fined-after-following-some-very-bad-advice/" class="tptn_link"><span class="tptn_title">Man fined after following some very bad advice</span></a><span class="tptn_excerpt"> H.P. court docketMonday, Nov. 30Judge D.R. Shynkar A local man was fined $388 after pleading guilty in High&hellip;</span></span></li><li><a href="https://www.southpeacenews.com/covid-19-mini-update-december-8-2020/" class="tptn_link"><img width="64" height="64" src="https://www.southpeacenews.com/wp-content/uploads/2020/04/COVID19_3-64x64.png" class="tptn_thumb tptn_featured" alt="COVID-19 Mini-UPDATE – December 8, 2020" title="COVID-19 Mini-UPDATE – December 8, 2020" /></a><span class="tptn_after_thumb"><a href="https://www.southpeacenews.com/covid-19-mini-update-december-8-2020/" class="tptn_link"><span class="tptn_title">COVID-19 Mini-UPDATE – December 8, 2020</span></a><span class="tptn_excerpt"> As of December 8, Alberta Health confirmed 1,727 new cases since Dec. 7. There are 165 new cases&hellip;</span></span></li></ul><div class="tptn_clear"></div></div></aside><aside id="ajdg_grpwidgets-11" class="widget ajdg_grpwidgets"><div class="g g-3"><div class="g-dyn a-846 c-1"><a class="gofollow" data-track="ODQ2LDMsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2020/02/ChurchDirectory_SIDE.png" /></a></div><div class="g-dyn a-803 c-2"><a class="gofollow" data-track="ODAzLDMsMSw2MA==" href="https://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/12/MaherAuto_OilChange_SIDE.png" /></a></div><div class="g-dyn a-1092 c-3"><a class="gofollow" data-track="MTA5MiwzLDEsNjA=" href="https://www.southpeacenews.com/employment/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPAGSociety_Caretaker_SIDE.png" /></a></div><div class="g-dyn a-1089 c-4"><a class="gofollow" data-track="MTA4OSwzLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/Marigold_FarmersMarket_SIDE.png" /></a></div><div class="g-dyn a-857 c-5"><a class="gofollow" data-track="ODU3LDMsMSw2MA==" href="http://classified.citylive.com/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Classifieds1_SIDE.png" /></a></div><div class="g-dyn a-852 c-6"><a class="gofollow" data-track="ODUyLDMsMSw2MA==" href="https://southpeacenews.com/select-contest/"><img src="http://southpeacenews.com/wp-content/uploads/2020/03/Select_TooloftheWeek_SIDE.png" /></a></div><div class="g-dyn a-1109 c-7"><a class="gofollow" data-track="MTEwOSwzLDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/A1_hours_SIDE.png" /></a></div><div class="g-dyn a-1085 c-8"><a class="gofollow" data-track="MTA4NSwzLDEsNjA=" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/GlamourGear_HolidayHours_SIDE.png" /></a></div><div class="g-dyn a-1006 c-9"><a class="gofollow" data-track="MTAwNiwzLDEsNjA=" href="http://southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/BusinessDirectory1_SIDE.png" /></a></div><div class="g-dyn a-1098 c-10"><a class="gofollow" data-track="MTA5OCwzLDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/Marigolds_Hours1_SIDE.png" /></a></div><div class="g-dyn a-998 c-11"><a class="gofollow" data-track="OTk4LDMsMSw2MA==" href="https://www.southpeacenews.com/general/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/10/HPSD1_SIDE.png" /></a></div><div class="g-dyn a-1081 c-12"><a class="gofollow" data-track="MTA4MSwzLDEsNjA=" href="https://www.southpeacenews.com/services/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/HagenBisonRanch_SIDE.png" /></a></div><div class="g-dyn a-1077 c-13"><a class="gofollow" data-track="MTA3NywzLDEsNjA=" href="https://www.southpeacenews.com/sales/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/11/Marigold_CookieBoxes_SIDE.png" /></a></div><div class="g-dyn a-1101 c-14"><a class="gofollow" data-track="MTEwMSwzLDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/AprilIsidore_VOTE_SIDE.png" /></a></div><div class="g-dyn a-639 c-15"><a class="gofollow" data-track="NjM5LDMsMSw2MA==" href="http://southpeacenews.com/services/"><img src="http://southpeacenews.com/wp-content/uploads/2019/02/Kaft_BusDir_BOTH_SIDE.png" /></a></div></div></aside><aside id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3165736599172791" data-ad-slot="6075938174" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside></div>
</main>
</div>
<div class="clearfix"></div>
<footer id="footer" class="site-footer clearfix" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="footer-column footer-column-1">
<aside id="text-4" class="widget widget_text"><h3 class="widget-title">SUPPORT INFORMATION</h3> <div class="textwidget"><p><a href="https://southpeacenews.com/get-alerts/">Sign Up for Email Alerts</a><br />
<a href="http://southpeacenews.com/contact/">Contact Us</a><br />
<a href="http://southpeacenews.com/about/">About The South Peace News</a><br />
<a href="http://southpeacenews.com/advertising-rates/">Online Advertising Rates</a></p>
</div>
</aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">ARCHIVES</h3> <label class="screen-reader-text" for="archives-dropdown-2">ARCHIVES</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.southpeacenews.com/2020/12/'> December 2020 &nbsp;(113)</option>
<option value='https://www.southpeacenews.com/2020/11/'> November 2020 &nbsp;(159)</option>
<option value='https://www.southpeacenews.com/2020/10/'> October 2020 &nbsp;(153)</option>
<option value='https://www.southpeacenews.com/2020/09/'> September 2020 &nbsp;(174)</option>
<option value='https://www.southpeacenews.com/2020/08/'> August 2020 &nbsp;(121)</option>
<option value='https://www.southpeacenews.com/2020/07/'> July 2020 &nbsp;(148)</option>
<option value='https://www.southpeacenews.com/2020/06/'> June 2020 &nbsp;(180)</option>
<option value='https://www.southpeacenews.com/2020/05/'> May 2020 &nbsp;(182)</option>
<option value='https://www.southpeacenews.com/2020/04/'> April 2020 &nbsp;(219)</option>
<option value='https://www.southpeacenews.com/2020/03/'> March 2020 &nbsp;(216)</option>
<option value='https://www.southpeacenews.com/2020/02/'> February 2020 &nbsp;(123)</option>
<option value='https://www.southpeacenews.com/2020/01/'> January 2020 &nbsp;(146)</option>
<option value='https://www.southpeacenews.com/2019/12/'> December 2019 &nbsp;(152)</option>
<option value='https://www.southpeacenews.com/2019/11/'> November 2019 &nbsp;(147)</option>
<option value='https://www.southpeacenews.com/2019/10/'> October 2019 &nbsp;(182)</option>
<option value='https://www.southpeacenews.com/2019/09/'> September 2019 &nbsp;(143)</option>
<option value='https://www.southpeacenews.com/2019/08/'> August 2019 &nbsp;(109)</option>
<option value='https://www.southpeacenews.com/2019/07/'> July 2019 &nbsp;(179)</option>
<option value='https://www.southpeacenews.com/2019/06/'> June 2019 &nbsp;(148)</option>
<option value='https://www.southpeacenews.com/2019/05/'> May 2019 &nbsp;(135)</option>
<option value='https://www.southpeacenews.com/2019/04/'> April 2019 &nbsp;(156)</option>
<option value='https://www.southpeacenews.com/2019/03/'> March 2019 &nbsp;(117)</option>
<option value='https://www.southpeacenews.com/2019/02/'> February 2019 &nbsp;(75)</option>
<option value='https://www.southpeacenews.com/2019/01/'> January 2019 &nbsp;(128)</option>
<option value='https://www.southpeacenews.com/2018/12/'> December 2018 &nbsp;(90)</option>
<option value='https://www.southpeacenews.com/2018/11/'> November 2018 &nbsp;(141)</option>
<option value='https://www.southpeacenews.com/2018/10/'> October 2018 &nbsp;(133)</option>
<option value='https://www.southpeacenews.com/2018/09/'> September 2018 &nbsp;(111)</option>
<option value='https://www.southpeacenews.com/2018/08/'> August 2018 &nbsp;(108)</option>
<option value='https://www.southpeacenews.com/2018/07/'> July 2018 &nbsp;(152)</option>
<option value='https://www.southpeacenews.com/2018/06/'> June 2018 &nbsp;(120)</option>
<option value='https://www.southpeacenews.com/2018/05/'> May 2018 &nbsp;(138)</option>
<option value='https://www.southpeacenews.com/2018/04/'> April 2018 &nbsp;(135)</option>
<option value='https://www.southpeacenews.com/2018/03/'> March 2018 &nbsp;(151)</option>
<option value='https://www.southpeacenews.com/2018/02/'> February 2018 &nbsp;(134)</option>
<option value='https://www.southpeacenews.com/2018/01/'> January 2018 &nbsp;(119)</option>
<option value='https://www.southpeacenews.com/2017/12/'> December 2017 &nbsp;(133)</option>
<option value='https://www.southpeacenews.com/2017/11/'> November 2017 &nbsp;(140)</option>
<option value='https://www.southpeacenews.com/2017/10/'> October 2017 &nbsp;(152)</option>
<option value='https://www.southpeacenews.com/2017/09/'> September 2017 &nbsp;(130)</option>
<option value='https://www.southpeacenews.com/2017/08/'> August 2017 &nbsp;(113)</option>
<option value='https://www.southpeacenews.com/2017/07/'> July 2017 &nbsp;(138)</option>
<option value='https://www.southpeacenews.com/2017/06/'> June 2017 &nbsp;(153)</option>
<option value='https://www.southpeacenews.com/2017/05/'> May 2017 &nbsp;(159)</option>
<option value='https://www.southpeacenews.com/2017/04/'> April 2017 &nbsp;(144)</option>
<option value='https://www.southpeacenews.com/2017/03/'> March 2017 &nbsp;(142)</option>
<option value='https://www.southpeacenews.com/2017/02/'> February 2017 &nbsp;(118)</option>
<option value='https://www.southpeacenews.com/2017/01/'> January 2017 &nbsp;(117)</option>
<option value='https://www.southpeacenews.com/2016/12/'> December 2016 &nbsp;(151)</option>
<option value='https://www.southpeacenews.com/2016/11/'> November 2016 &nbsp;(136)</option>
<option value='https://www.southpeacenews.com/2016/10/'> October 2016 &nbsp;(178)</option>
<option value='https://www.southpeacenews.com/2016/09/'> September 2016 &nbsp;(154)</option>
<option value='https://www.southpeacenews.com/2016/08/'> August 2016 &nbsp;(147)</option>
<option value='https://www.southpeacenews.com/2016/07/'> July 2016 &nbsp;(153)</option>
<option value='https://www.southpeacenews.com/2016/06/'> June 2016 &nbsp;(172)</option>
<option value='https://www.southpeacenews.com/2016/05/'> May 2016 &nbsp;(159)</option>
<option value='https://www.southpeacenews.com/2016/04/'> April 2016 &nbsp;(73)</option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</aside><aside id="text-10" class="widget widget_text"><h3 class="widget-title">PURLS To Brighten Your Day</h3> <div class="textwidget"><p>Advertiser Sale of The Week &#8211; Coming<br />
Recipe &#8211; Coming<br />
Canada Home of The Week &#8211; Coming<br />
Coffee Break &#8211; Coming<br />
Top Headline &#8211; Coming</p>
<p>&nbsp;</p>
</div>
</aside> </div>
<div class="footer-column footer-column-2">
<aside id="ajdg_grpwidgets-4" class="widget ajdg_grpwidgets"><div class="g g-6"><div class="g-dyn a-1116 c-1"><a class="gofollow" data-track="MTExNiw2LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/SPN_CG_SIDE.png" /></a></div><div class="g-dyn a-1117 c-2"><a class="gofollow" data-track="MTExNyw2LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HolidayGreetings_SIDE.png" /></a></div><div class="g-dyn a-1118 c-3"><a class="gofollow" data-track="MTExOCw2LDEsNjA=" href="https://www.southpeacenews.com/get-alerts/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/SignUp_SIDE.png" /></a></div><div class="g-dyn a-1113 c-4"><a class="gofollow" data-track="MTExMyw2LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/HPMedicalClinic_CG_SIDE.png" /></a></div><div class="g-dyn a-1112 c-5"><a class="gofollow" data-track="MTExMiw2LDEsNjA=" href="https://www.southpeacenews.com/notices/"><img src="https://www.southpeacenews.com/wp-content/uploads/2020/12/2PRSchoolDivision_CG_SIDE.png" /></a></div></div></aside> </div>
<div class="footer-column footer-column-3">
<aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/quotegen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside> </div>
<div class="footer-column footer-column-4">
<aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe style="border: 1px solid black" src="https://contentkings.com/laughgen01/" width="300" height="340" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></div></aside> </div>
<div id="site-bottom" class="clearfix">
<div class="copyright"><div class="left">&copy; 2020 <a href="https://www.southpeacenews.com" title="" rel="home"></a>. All rights reserved.</div><div class="right">Built by South Peace News</div></div>
</div>
</footer>
</div>

<script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>


<script type="text/javascript">
var cfflinkhashtags = "true";
</script>
<script>document.documentElement.className = 'js';</script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://www.southpeacenews.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "8d8fdb7b11", post_id : 38147 } ); } ); /* ]]> */</script>
<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1' id='awesome_weather-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.southpeacenews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.1' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/custom-facebook-feed/js/cff-scripts.js?ver=2.17.1' id='cffscripts-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/www.southpeacenews.com\/wp-admin\/admin-ajax.php","top_ten_id":"38147","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"1359342504"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0' id='tptn_tracker-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE&#038;ver=3.0' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcCwoAUAAAAAMlLkuN8L2m6d8gCJ2K7JJbls3mE","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js?ver=5.3.1' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/themes/freshlife/assets/js/freshlife.min.js' id='freshlife-scripts-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.4' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.southpeacenews.com/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.southpeacenews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>
<script type="text/javascript">

		$(document).ready(function(){
			$('#primary-menu').slicknav({
				prependTo:'#primary-bar',
				label: "PAGES"
			});
			$('#secondary-menu').slicknav({
				prependTo:'#secondary-bar',
				label: "CATEGORIES"
			});
		});

	</script>

<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-2').gslider({groupid:2,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-4').gslider({groupid:4,speed:8000,repeat_impressions:'Y'});
	jQuery('.g-5').gslider({groupid:5,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-7').gslider({groupid:7,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-8').gslider({groupid:8,speed:4000,repeat_impressions:'Y'});
	jQuery('.g-9').gslider({groupid:9,speed:7000,repeat_impressions:'Y'});
	jQuery('.g-10').gslider({groupid:10,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-11').gslider({groupid:11,speed:3000,repeat_impressions:'Y'});
}});
</script>

</body>
</html>